summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-08-17 21:24:58 +0200
committerHans de Graaff <graaff@gentoo.org>2021-08-18 06:00:28 +0200
commite1293eb43aab45c44539c94daf2d0e1165bcbcc2 (patch)
treeddcb0faabf998ea7d9a0ea36117da3f010d7b955 /dev-ruby/typeprof/typeprof-0.15.1.ebuild
parentnet-print/cups-filters: add 1.28.10 (diff)
downloadgentoo-e1293eb43aab45c44539c94daf2d0e1165bcbcc2.tar.gz
gentoo-e1293eb43aab45c44539c94daf2d0e1165bcbcc2.tar.bz2
gentoo-e1293eb43aab45c44539c94daf2d0e1165bcbcc2.zip
dev-ruby/typeprof: add 0.15.1
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/typeprof/typeprof-0.15.1.ebuild')
-rw-r--r--dev-ruby/typeprof/typeprof-0.15.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ruby/typeprof/typeprof-0.15.1.ebuild b/dev-ruby/typeprof/typeprof-0.15.1.ebuild
new file mode 100644
index 000000000000..ac6c1869b325
--- /dev/null
+++ b/dev-ruby/typeprof/typeprof-0.15.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby27 ruby30"
+
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_BINDIR="exe"
+
+RUBY_FAKEGEM_GEMSPEC="typeprof.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Performs a type analysis of non-annotated Ruby code"
+HOMEPAGE="https://github.com/ruby/typeprof"
+SRC_URI="https://github.com/ruby/typeprof/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE="test"
+
+ruby_add_rdepend ">=dev-ruby/rbs-1.3.1"
+
+all_ruby_prepare() {
+ # Avoid tests that download live code using git
+ rm -r test/typeprof/{goodcheck,diff-lcs}_test.rb || die
+
+ sed -i -e "s:_relative ': './:" -e 's/git ls-files -z/find * -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+}