summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-02-04 06:54:12 +0100
committerHans de Graaff <graaff@gentoo.org>2021-02-04 06:54:12 +0100
commit4ba0cb7c86fed538c24d7bc8bf4ce9786facb7d9 (patch)
tree108f8a19a763300d17635b730e0a006d57a96eb9 /dev-ruby/typeprof
parentdev-ruby/rubygems: cleanup (diff)
downloadgentoo-4ba0cb7c86fed538c24d7bc8bf4ce9786facb7d9.tar.gz
gentoo-4ba0cb7c86fed538c24d7bc8bf4ce9786facb7d9.tar.bz2
gentoo-4ba0cb7c86fed538c24d7bc8bf4ce9786facb7d9.zip
dev-ruby/typeprof: add 0.12.0
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/typeprof')
-rw-r--r--dev-ruby/typeprof/Manifest1
-rw-r--r--dev-ruby/typeprof/typeprof-0.12.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-ruby/typeprof/Manifest b/dev-ruby/typeprof/Manifest
index ddf52bd76c02..42d122904096 100644
--- a/dev-ruby/typeprof/Manifest
+++ b/dev-ruby/typeprof/Manifest
@@ -1 +1,2 @@
DIST typeprof-0.11.0.tar.gz 496673 BLAKE2B 215bd738a4a4b9e7de78943a944fd63dd4f166f215a493cdc89270e0452453683d3fdd1f71ccc05f4399f61e120248a73ed9b77b5b24ed4aa8b54e97d9e0073d SHA512 cc64bd805c57a16c275ba5622df08ff30fd64ae82b18e29fb30e03d17a6ca0e889c03696c745597bfec6444290f1f33020c4bd9c49a02fc3053add33e3e60084
+DIST typeprof-0.12.0.tar.gz 497398 BLAKE2B 149d382c5598ce3cfa023133095190e00e083ac445019c4aedf59d66005db93241dacd9c724f2b62e64d02aa3d7f4a58a3fa4546256c872030687574112c7333 SHA512 a28bc10ce19f7a3afe940cb01fd443c89a87497be2be0b03d92684581c4ffdc061e8e5119652116884e4cf0e5c0ea7d9a73c0f8be2a666d6bbe71e81bada323b
diff --git a/dev-ruby/typeprof/typeprof-0.12.0.ebuild b/dev-ruby/typeprof/typeprof-0.12.0.ebuild
new file mode 100644
index 000000000000..620e94ea93ee
--- /dev/null
+++ b/dev-ruby/typeprof/typeprof-0.12.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby27 ruby30"
+
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_BINDIR="exe"
+
+RUBY_FAKEGEM_GEMSPEC="typeprof.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Performs a type analysis of non-annotated Ruby code"
+HOMEPAGE="https://github.com/ruby/typeprof"
+SRC_URI="https://github.com/ruby/typeprof/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE="test"
+
+ruby_add_rdepend ">=dev-ruby/rbs-1.0.0"
+
+all_ruby_prepare() {
+ # Avoid tests that download live code using git
+ rm -r test/typeprof/{goodcheck,diff-lcs}_test.rb || die
+
+ sed -i -e "s:_relative ': './:" ${RUBY_FAKEGEM_GEMSPEC} || die
+}