summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2015-08-24 07:32:59 +0200
committerHans de Graaff <graaff@gentoo.org>2015-08-24 07:32:59 +0200
commit704efb814945736c0d1b89af84b2c24b13496b49 (patch)
tree343a575cbb64b37fbbe1a9525d03b6f86304e3a1 /dev-ruby/tzinfo/tzinfo-0.3.44.ebuild
parentdev-ruby/rack: version bump (diff)
downloadgentoo-704efb814945736c0d1b89af84b2c24b13496b49.tar.gz
gentoo-704efb814945736c0d1b89af84b2c24b13496b49.tar.bz2
gentoo-704efb814945736c0d1b89af84b2c24b13496b49.zip
dev-ruby/tzinfo: version bump
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-ruby/tzinfo/tzinfo-0.3.44.ebuild')
-rw-r--r--dev-ruby/tzinfo/tzinfo-0.3.44.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-ruby/tzinfo/tzinfo-0.3.44.ebuild b/dev-ruby/tzinfo/tzinfo-0.3.44.ebuild
new file mode 100644
index 000000000000..7760b20ca92b
--- /dev/null
+++ b/dev-ruby/tzinfo/tzinfo-0.3.44.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGES README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Daylight-savings aware timezone library"
+HOMEPAGE="http://tzinfo.github.io/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND=""
+DEPEND=""
+
+all_ruby_prepare() {
+ # With rubygems 1.3.1 we get the following warning
+ # warning: Insecure world writable dir /var/tmp in LOAD_PATH, mode 041777
+ # when running the test_get_tainted_not_loaded test.
+ sed -i \
+ -e '/^ def test_get_tainted_not_loaded/, /^ end/ s:^:#:' \
+ "${S}"/test/tc_timezone.rb || die "unable to sed out the test"
+}
+
+each_ruby_test() {
+ TZ='America/Los_Angeles' ${RUBY} -I. -S testrb test/tc_*.rb || die
+}