summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/uconv
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/uconv')
-rw-r--r--dev-ruby/uconv/Manifest1
-rw-r--r--dev-ruby/uconv/metadata.xml5
-rw-r--r--dev-ruby/uconv/uconv-0.6.1-r1.ebuild38
-rw-r--r--dev-ruby/uconv/uconv-0.6.1-r2.ebuild38
4 files changed, 82 insertions, 0 deletions
diff --git a/dev-ruby/uconv/Manifest b/dev-ruby/uconv/Manifest
new file mode 100644
index 000000000000..ccedd5b6efcc
--- /dev/null
+++ b/dev-ruby/uconv/Manifest
@@ -0,0 +1 @@
+DIST uconv-0.6.1.tar.gz 740417 SHA256 8723456da3899408b3d593c2eca9956834293b6dff9a54e9efb5dfe5ae813363 SHA512 6f964e42886f498bd6c4111e522143d8d958b8c6e401d26f784fdf1441684f1fde7cfdc35a08d3707a42e305d5508d9ff3fbc1b735298f8af2aae3923cbda68d WHIRLPOOL 0e2215c2de1e91b3d8045c2d576791f09d6d783a13fae02ef548c0715367b05ffb85bc5f932c21a0dec92e15e8d6db62eea88093c1402da08572aa4de205b3f3
diff --git a/dev-ruby/uconv/metadata.xml b/dev-ruby/uconv/metadata.xml
new file mode 100644
index 000000000000..852136183369
--- /dev/null
+++ b/dev-ruby/uconv/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>
diff --git a/dev-ruby/uconv/uconv-0.6.1-r1.ebuild b/dev-ruby/uconv/uconv-0.6.1-r1.ebuild
new file mode 100644
index 000000000000..efc1eddba3e8
--- /dev/null
+++ b/dev-ruby/uconv/uconv-0.6.1-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20"
+
+inherit ruby-ng
+
+DESCRIPTION="A module to convert ISO/IEC 10646 (Unicode) string and Japanese strings"
+HOMEPAGE="http://www.yoshidam.net/Ruby.html#uconv"
+SRC_URI="http://www.yoshidam.net/${P}.tar.gz"
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~amd64 ppc ppc64 x86"
+IUSE=""
+
+RUBY_S=${PN}
+
+all_ruby_prepare() {
+ sed -i -e '/^\$CFLAGS = ""/d' extconf.rb || die "Unable to remove CFLAGS line"
+}
+
+each_ruby_configure() {
+ ${RUBY} extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake V=1
+}
+
+each_ruby_install() {
+ emake V=1 DESTDIR="${D}" install
+}
+
+all_ruby_install() {
+ dodoc README*
+}
diff --git a/dev-ruby/uconv/uconv-0.6.1-r2.ebuild b/dev-ruby/uconv/uconv-0.6.1-r2.ebuild
new file mode 100644
index 000000000000..b820e5f9e416
--- /dev/null
+++ b/dev-ruby/uconv/uconv-0.6.1-r2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+inherit ruby-ng
+
+DESCRIPTION="A module to convert ISO/IEC 10646 (Unicode) string and Japanese strings"
+HOMEPAGE="http://www.yoshidam.net/Ruby.html#uconv"
+SRC_URI="http://www.yoshidam.net/${P}.tar.gz"
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RUBY_S=${PN}
+
+all_ruby_prepare() {
+ sed -i -e '/^\$CFLAGS = ""/d' extconf.rb || die "Unable to remove CFLAGS line"
+}
+
+each_ruby_configure() {
+ ${RUBY} extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake V=1
+}
+
+each_ruby_install() {
+ emake V=1 DESTDIR="${D}" install
+}
+
+all_ruby_install() {
+ dodoc README*
+}