summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-11-23 12:43:02 +0100
committerHans de Graaff <graaff@gentoo.org>2021-11-24 07:37:12 +0100
commitd9b89339f6cdfff7cc17fa91e22622be29d9bc6f (patch)
treeb0267b68aa9fab883ab2dc2e8e72cdc9391c3d42 /dev-ruby/unf
parentdev-ruby/hamster: cleanup (diff)
downloadgentoo-d9b89339f6cdfff7cc17fa91e22622be29d9bc6f.tar.gz
gentoo-d9b89339f6cdfff7cc17fa91e22622be29d9bc6f.tar.bz2
gentoo-d9b89339f6cdfff7cc17fa91e22622be29d9bc6f.zip
dev-ruby/unf: EAPI 8
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/unf')
-rw-r--r--dev-ruby/unf/unf-0.1.4-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-ruby/unf/unf-0.1.4-r1.ebuild b/dev-ruby/unf/unf-0.1.4-r1.ebuild
new file mode 100644
index 000000000000..442d4c7d5a2c
--- /dev/null
+++ b/dev-ruby/unf/unf-0.1.4-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_RECIPE_TEST="none"
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A wrapper library to bring Unicode Normalization Form support to Ruby/JRuby"
+HOMEPAGE="https://github.com/knu/ruby-unf"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+IUSE="test"
+
+ruby_add_rdepend "dev-ruby/unf_ext"
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/test-unit-2.5.1-r1
+ dev-ruby/shoulda
+ )"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/,/end/ d' test/helper.rb || die
+
+ # Remove development dependencies; also remove platform as we don't
+ # care about it as it is, they only use it to avoid the unf_ext dep
+ # that we tackle on our own; finally remove git ls-files usage.
+ sed -i -e '/dependency.*\(shoulda\|bundler\|jeweler\|rcov\)/d' \
+ -e '/platform/d' \
+ -e '/git ls/d' \
+ ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+each_ruby_test() {
+ ruby-ng_testrb-2 test/test_*.rb
+}