summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-01-31 08:31:46 +0100
committerHans de Graaff <graaff@gentoo.org>2021-01-31 08:31:46 +0100
commitba1112ced0a46f7d8889afd789c4eb08b9d3229a (patch)
tree55967d1d7f59ff2369dfe59479fce9ce5b8ad7b7 /dev-ruby/unicode-display_width/unicode-display_width-2.0.0.ebuild
parentdev-ruby/test-unit: add 3.4.0 (diff)
downloadgentoo-ba1112ced0a46f7d8889afd789c4eb08b9d3229a.tar.gz
gentoo-ba1112ced0a46f7d8889afd789c4eb08b9d3229a.tar.bz2
gentoo-ba1112ced0a46f7d8889afd789c4eb08b9d3229a.zip
dev-ruby/unicode-display_width: add 2.0.0
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/unicode-display_width/unicode-display_width-2.0.0.ebuild')
-rw-r--r--dev-ruby/unicode-display_width/unicode-display_width-2.0.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/unicode-display_width/unicode-display_width-2.0.0.ebuild b/dev-ruby/unicode-display_width/unicode-display_width-2.0.0.ebuild
new file mode 100644
index 000000000000..bb32c9542642
--- /dev/null
+++ b/dev-ruby/unicode-display_width/unicode-display_width-2.0.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRAINSTALL="data"
+
+RUBY_FAKEGEM_GEMSPEC="unicode-display_width.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Adds String#display_width to get the display size using EastAsianWidth.txt"
+HOMEPAGE="https://github.com/janlelis/unicode-display_width"
+SRC_URI="https://github.com/janlelis/unicode-display_width/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~arm64"
+SLOT="$(ver_cut 1)"
+IUSE=""
+
+all_ruby_prepare() {
+ # Avoid experimental emoji support for now
+ sed -e '/\[emoji\]/,/^ end/ s:^:#:' \
+ -e '/Config object based API/,/^end/ s:^:#:' \
+ -i spec/display_width_spec.rb || die
+}