summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2020-01-17 12:34:02 -0800
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2020-01-17 12:34:02 -0800
commit5e14bd3a9ec9a4871a72ef2897095d19a0cfb99f (patch)
treef38cfae41a18145495bb2d97e17380255d2fedc1 /dev-ruby/vagrant_cloud/vagrant_cloud-2.0.3-r1.ebuild
parentdev-lang/php: security cleanup (bug #703326) (diff)
downloadgentoo-5e14bd3a9ec9a4871a72ef2897095d19a0cfb99f.tar.gz
gentoo-5e14bd3a9ec9a4871a72ef2897095d19a0cfb99f.tar.bz2
gentoo-5e14bd3a9ec9a4871a72ef2897095d19a0cfb99f.zip
dev-ruby/vagrant_cloud: revbump 2.0.3 to work with later rest-client
Closes: https://bugs.gentoo.org/705342 Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'dev-ruby/vagrant_cloud/vagrant_cloud-2.0.3-r1.ebuild')
-rw-r--r--dev-ruby/vagrant_cloud/vagrant_cloud-2.0.3-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ruby/vagrant_cloud/vagrant_cloud-2.0.3-r1.ebuild b/dev-ruby/vagrant_cloud/vagrant_cloud-2.0.3-r1.ebuild
new file mode 100644
index 000000000000..c3ef5f12f0f1
--- /dev/null
+++ b/dev-ruby/vagrant_cloud/vagrant_cloud-2.0.3-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2018-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_RECIPE_DOC="none"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Vagrant Cloud API Library"
+HOMEPAGE="https://github.com/hashicorp/vagrant_cloud"
+SRC_URI="https://github.com/hashicorp/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/rest-client:2"
+ruby_add_bdepend ">=dev-ruby/rake-10.4
+ test? ( >=dev-ruby/webmock-3.0 )"
+
+all_ruby_prepare() {
+ sed -i -e '/rubocop/I s:^:#:' Rakefile || die
+ # loosen dependencies
+ sed -e '/rest-client/s/~>/>=/' -i ${PN}.gemspec || die
+}