summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2019-12-01 17:21:26 -0500
committerMichael Orlitzky <mjo@gentoo.org>2019-12-01 17:21:48 -0500
commit60b8cdb4e8ecc9221ae96f8728949af74505d9d5 (patch)
tree09236326b2fff654ce98efede3210fa4264270cd /dev-ruby/vcard/vcard-0.2.16.ebuild
parentpackage.mask: Include media-plugins/vdr-coverviewer (diff)
downloadgentoo-60b8cdb4e8ecc9221ae96f8728949af74505d9d5.tar.gz
gentoo-60b8cdb4e8ecc9221ae96f8728949af74505d9d5.tar.bz2
gentoo-60b8cdb4e8ecc9221ae96f8728949af74505d9d5.zip
dev-ruby/vcard: new version 0.2.16 that supports newer rubies.
Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'dev-ruby/vcard/vcard-0.2.16.ebuild')
-rw-r--r--dev-ruby/vcard/vcard-0.2.16.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ruby/vcard/vcard-0.2.16.ebuild b/dev-ruby/vcard/vcard-0.2.16.ebuild
new file mode 100644
index 000000000000..fab4526db1a1
--- /dev/null
+++ b/dev-ruby/vcard/vcard-0.2.16.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby23 ruby24 ruby25 ruby26"
+
+# Avoid the complexity of the "rake" recipe and run testrb-2 manually.
+RUBY_FAKEGEM_RECIPE_TEST=none
+RUBY_FAKEGEM_RECIPE_DOC=none
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby vcard support extracted from Vpim"
+HOMEPAGE="https://github.com/qoobaa/vcard"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/test-unit:2 )"
+
+each_ruby_test() {
+ ruby-ng_testrb-2 --load-path=lib --pattern='.*_test\.rb' test/
+}