summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-02-26 06:43:48 +0100
committerHans de Graaff <graaff@gentoo.org>2020-02-26 06:43:48 +0100
commitaec3f96cad145b0b7e86553b22445b3c877bd667 (patch)
treec5bc7ea272bf5b12de0965de5ee6aacc73aaf9d6 /dev-ruby/vcr/vcr-5.1.0.ebuild
parentRevert dev-python/pyzmq py2 and net-wireless/urh update (diff)
downloadgentoo-aec3f96cad145b0b7e86553b22445b3c877bd667.tar.gz
gentoo-aec3f96cad145b0b7e86553b22445b3c877bd667.tar.bz2
gentoo-aec3f96cad145b0b7e86553b22445b3c877bd667.zip
dev-ruby/vcr: add 5.1.0
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/vcr/vcr-5.1.0.ebuild')
-rw-r--r--dev-ruby/vcr/vcr-5.1.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ruby/vcr/vcr-5.1.0.ebuild b/dev-ruby/vcr/vcr-5.1.0.ebuild
new file mode 100644
index 000000000000..ca4669a2923a
--- /dev/null
+++ b/dev-ruby/vcr/vcr-5.1.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby24 ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md CONTRIBUTING.md README.md Upgrade.md"
+
+RUBY_FAKEGEM_GEMSPEC="vcr.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Records your test suite's HTTP interactions and replay them during test runs"
+HOMEPAGE="https://github.com/vcr/vcr/"
+SRC_URI="https://github.com/vcr/vcr/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+SLOT="$(ver_cut 1)"
+IUSE="test"
+
+# Tests require all supported HTTP libraries to be present, and it is
+# not possible to avoid some of them without very extensive patches.
+RESTRICT="test"