summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-09-01 07:14:21 +0200
committerHans de Graaff <graaff@gentoo.org>2020-09-01 07:14:21 +0200
commitad31480ab7e4d260ba09e2072d340600ba3ee50c (patch)
treee9b51eb49715ea9cc927cd6d4e5146ba23000e73 /dev-ruby/warden/warden-1.2.9.ebuild
parentdev-ruby/minitest: add 5.14.2 (diff)
downloadgentoo-ad31480ab7e4d260ba09e2072d340600ba3ee50c.tar.gz
gentoo-ad31480ab7e4d260ba09e2072d340600ba3ee50c.tar.bz2
gentoo-ad31480ab7e4d260ba09e2072d340600ba3ee50c.zip
dev-ruby/warden: add 1.2.9
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/warden/warden-1.2.9.ebuild')
-rw-r--r--dev-ruby/warden/warden-1.2.9.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/warden/warden-1.2.9.ebuild b/dev-ruby/warden/warden-1.2.9.ebuild
new file mode 100644
index 000000000000..8075b9c43785
--- /dev/null
+++ b/dev-ruby/warden/warden-1.2.9.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="General Rack Authentication Framework"
+HOMEPAGE="https://github.com/wardencommunity/warden"
+SRC_URI="https://github.com/wardencommunity/warden/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+
+KEYWORDS="~amd64"
+SLOT="0"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/rack-2.0.9:*"
+
+all_ruby_prepare() {
+ sed -i -e 's/git ls-files -z/find . -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+}