summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-01-19 07:41:04 +0100
committerHans de Graaff <graaff@gentoo.org>2021-01-19 18:24:25 +0100
commit3a6ae8bebd4d2fe8f274f9e1ae4cdbe4e9cf8830 (patch)
tree7f6ed9b95e5de8db8347827c1035d9dbb116f611 /dev-ruby/webmock
parentdev-ruby/sshkit: add 1.21.2 (diff)
downloadgentoo-3a6ae8bebd4d2fe8f274f9e1ae4cdbe4e9cf8830.tar.gz
gentoo-3a6ae8bebd4d2fe8f274f9e1ae4cdbe4e9cf8830.tar.bz2
gentoo-3a6ae8bebd4d2fe8f274f9e1ae4cdbe4e9cf8830.zip
dev-ruby/webmock: cleanup
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/webmock')
-rw-r--r--dev-ruby/webmock/Manifest2
-rw-r--r--dev-ruby/webmock/webmock-3.8.1.ebuild61
-rw-r--r--dev-ruby/webmock/webmock-3.8.2.ebuild61
3 files changed, 0 insertions, 124 deletions
diff --git a/dev-ruby/webmock/Manifest b/dev-ruby/webmock/Manifest
index a93538b330c4..820b5133358a 100644
--- a/dev-ruby/webmock/Manifest
+++ b/dev-ruby/webmock/Manifest
@@ -1,5 +1,3 @@
DIST webmock-3.11.0.gem 125440 BLAKE2B 8c57ca5b49922a61590595cdeeb5d3306edb3be616fd8e5c68617838831537f2106664201580f645de58322f11e684dfc8404d91139eaead5810c0cb40d5dc1f SHA512 dda7318d32dd88dcd4bc1fee9d1f4644f272348b532cbb59afde2e6a1fc42f359125b28d605ff1a18edac4ed71c00aceb1c67a364c15cfa56092e226588b449c
DIST webmock-3.7.6.gem 122368 BLAKE2B 9bc40971f1eec96d88217544acc67b7abfe6c0815a0696119e12fc5629b4f51e1164ecc982525d2c02fa50c7b1b09548c4831c1d597f06acde04a83227ba0dc9 SHA512 85455495476b22d94b23e34a92db3f0f8cf1aa5bb52ea6a8eb71f5f0bcbdad1edc13dff778c62806ec27850320e9f4e17f12525bbac552e5e105ee1ecd771efd
-DIST webmock-3.8.1.gem 122368 BLAKE2B ba956c72f20e2c21cea90b107ef445e42a6995fdb31f9af65c3b561e9e1fbb9fbd299db009a1d83ddfdb473ce030d40aadf6633e23afbd072ee3b4debf7e0be2 SHA512 b1137fabb000469ee88fdd5521756f368463ee49988d5d89b51fa8352362ff249a4849159504834933e5e1248ed9b6791d254528b3cdea461fc9e8e5d92a334c
-DIST webmock-3.8.2.gem 122880 BLAKE2B 0cd10f391377749c6420d08434c8e66230612c50bdff86b4dfd098690c006426e241c32bf716e2f8b9ee6c0ce6488d1975b54f3e4cd85cc14d6c7f0880f65701 SHA512 ae6bdda341bea804257d9f9b57d17a65a25d030ee2f5a9b7fff125a5f7881a34584c6b5d26a1e6dd5a49bba56ad5b6e731defecd109e19a5144df4caf90561d4
DIST webmock-3.8.3.gem 122880 BLAKE2B 66371028294f3b15172d718e0fa9402ad6ed1bf7beedb0c62621ad31758d25e401af9cd982a6f29cd1161a7e4d7954f6f9df22ab2e0c44c970a0edca3c0f1304 SHA512 6c845c4ed0c82ba4bb1f32d0d87a87eb945c54e159317aa14e2238b497d38282b7e81542e78c0d68d4b8d4a08e46137de84503829b7381e6d945e45474ebb507
diff --git a/dev-ruby/webmock/webmock-3.8.1.ebuild b/dev-ruby/webmock/webmock-3.8.1.ebuild
deleted file mode 100644
index 7b97e611140d..000000000000
--- a/dev-ruby/webmock/webmock-3.8.1.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-USE_RUBY="ruby24 ruby25 ruby26"
-
-RUBY_FAKEGEM_TASK_TEST="test spec NO_CONNECTION=true"
-
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Allows stubbing HTTP requests and setting expectations on HTTP requests"
-HOMEPAGE="https://github.com/bblimke/webmock"
-
-LICENSE="GPL-2"
-SLOT="3"
-KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris ~x86-solaris"
-IUSE=""
-
-ruby_add_rdepend ">=dev-ruby/addressable-2.3.6 >=dev-ruby/crack-0.3.2 >=dev-ruby/hashdiff-0.4.0:0"
-
-ruby_add_bdepend "test? (
- dev-ruby/minitest:5
- dev-ruby/rspec:3
- >=dev-ruby/test-unit-3.0.0
- dev-ruby/rack
- >=dev-ruby/httpclient-2.8.0
- || ( dev-ruby/http:4 dev-ruby/http:3 ) )"
-
-all_ruby_prepare() {
- # Remove bundler support
- rm Gemfile || die
- sed -i -e '/[Bb]undler/d' Rakefile || die
- sed -i -e '/simplecov/I s:^:#:' spec/spec_helper.rb || die
- sed -i -e '1igem "test-unit"' test/test_helper.rb || die
-
- # There is now optional support for curb and typhoeus which we don't
- # have in Gentoo yet. em_http_request is available in Gentoo but its
- # version is too old. patron's latest version is not compatible.
- sed -i -e '/\(curb\|typhoeus\|em-http\|patron\)/d' spec/spec_helper.rb || die
- rm spec/acceptance/{typhoeus,curb,excon,em_http_request,patron,async_http_client}/* || die
-
- # Avoid httpclient specs that require network access, most likely
- # because mocking does not fully work.
- sed -i -e '/httpclient streams response/,/^ end/ s:^:#:' \
- -e '/are detected when manually specifying Authorization header/,/^ end/ s:^:#:' \
- spec/acceptance/httpclient/httpclient_spec.rb
-
- # Avoid specs that require network access
- sed -i -e '/when request is not stubbed/,/^ end/ s:^:#:' spec/acceptance/shared/callbacks.rb
-}
-
-each_ruby_test() {
- ${RUBY} -S rake test NO_CONNECTION=true || die
- ${RUBY} -S rspec-3 spec || die
-
- einfo "Delay to allow the test server to stop"
- sleep 10
-}
diff --git a/dev-ruby/webmock/webmock-3.8.2.ebuild b/dev-ruby/webmock/webmock-3.8.2.ebuild
deleted file mode 100644
index 7b97e611140d..000000000000
--- a/dev-ruby/webmock/webmock-3.8.2.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-USE_RUBY="ruby24 ruby25 ruby26"
-
-RUBY_FAKEGEM_TASK_TEST="test spec NO_CONNECTION=true"
-
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Allows stubbing HTTP requests and setting expectations on HTTP requests"
-HOMEPAGE="https://github.com/bblimke/webmock"
-
-LICENSE="GPL-2"
-SLOT="3"
-KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris ~x86-solaris"
-IUSE=""
-
-ruby_add_rdepend ">=dev-ruby/addressable-2.3.6 >=dev-ruby/crack-0.3.2 >=dev-ruby/hashdiff-0.4.0:0"
-
-ruby_add_bdepend "test? (
- dev-ruby/minitest:5
- dev-ruby/rspec:3
- >=dev-ruby/test-unit-3.0.0
- dev-ruby/rack
- >=dev-ruby/httpclient-2.8.0
- || ( dev-ruby/http:4 dev-ruby/http:3 ) )"
-
-all_ruby_prepare() {
- # Remove bundler support
- rm Gemfile || die
- sed -i -e '/[Bb]undler/d' Rakefile || die
- sed -i -e '/simplecov/I s:^:#:' spec/spec_helper.rb || die
- sed -i -e '1igem "test-unit"' test/test_helper.rb || die
-
- # There is now optional support for curb and typhoeus which we don't
- # have in Gentoo yet. em_http_request is available in Gentoo but its
- # version is too old. patron's latest version is not compatible.
- sed -i -e '/\(curb\|typhoeus\|em-http\|patron\)/d' spec/spec_helper.rb || die
- rm spec/acceptance/{typhoeus,curb,excon,em_http_request,patron,async_http_client}/* || die
-
- # Avoid httpclient specs that require network access, most likely
- # because mocking does not fully work.
- sed -i -e '/httpclient streams response/,/^ end/ s:^:#:' \
- -e '/are detected when manually specifying Authorization header/,/^ end/ s:^:#:' \
- spec/acceptance/httpclient/httpclient_spec.rb
-
- # Avoid specs that require network access
- sed -i -e '/when request is not stubbed/,/^ end/ s:^:#:' spec/acceptance/shared/callbacks.rb
-}
-
-each_ruby_test() {
- ${RUBY} -S rake test NO_CONNECTION=true || die
- ${RUBY} -S rspec-3 spec || die
-
- einfo "Delay to allow the test server to stop"
- sleep 10
-}