summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-09-20 06:32:11 +0200
committerHans de Graaff <graaff@gentoo.org>2023-09-20 06:32:11 +0200
commit251924cdc1e34b141c075870ab9c3cdccc0a6494 (patch)
tree14cd94ef6f1157ec9f8fa9d7786db3d4e37ff992 /dev-ruby/websocket/websocket-1.2.10.ebuild
parentdev-python/absl-py: Enable py3.12 (diff)
downloadgentoo-251924cdc1e34b141c075870ab9c3cdccc0a6494.tar.gz
gentoo-251924cdc1e34b141c075870ab9c3cdccc0a6494.tar.bz2
gentoo-251924cdc1e34b141c075870ab9c3cdccc0a6494.zip
dev-ruby/websocket: add 1.2.10
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/websocket/websocket-1.2.10.ebuild')
-rw-r--r--dev-ruby/websocket/websocket-1.2.10.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ruby/websocket/websocket-1.2.10.ebuild b/dev-ruby/websocket/websocket-1.2.10.ebuild
new file mode 100644
index 000000000000..e1f235d0ecb9
--- /dev/null
+++ b/dev-ruby/websocket/websocket-1.2.10.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Universal Ruby library to handle WebSocket protocol"
+HOMEPAGE="https://github.com/imanel/websocket-ruby"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~x86"
+IUSE=""
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/rspec-its
+ dev-ruby/webrick
+ )
+"