summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-04-01 21:26:34 +0100
committerSam James <sam@gentoo.org>2023-04-02 00:18:40 +0100
commitc3dac4390ed021962d0b3e41b536aed955423d48 (patch)
tree0ef0042058a85214b1c7b1062def017af59b7299 /dev-ruby/websocket/websocket-1.2.9-r2.ebuild
parentdev-ruby/typeprof: drop 0.15.2 (diff)
downloadgentoo-c3dac4390ed021962d0b3e41b536aed955423d48.tar.gz
gentoo-c3dac4390ed021962d0b3e41b536aed955423d48.tar.bz2
gentoo-c3dac4390ed021962d0b3e41b536aed955423d48.zip
dev-ruby/websocket: enable ruby32, fix tests
- Enable ruby32 - Fix tests Fixing tests was interesting. I very quickly found the upstream commits touching the port deduction/specification bit, but I had no idea why this would've started failing on all Rubies all of a sudden yet. But ended up, after looking through MRI Ruby release notes, figured out it must be somewhere else (it didn't seem to be a backported bundled gem update). It looks like it's actually because of a change in an (undeclared) test dep - dev-ruby/webrick. It was probably https://github.com/ruby/webrick/pull/55 or similar, but enough to satisfy my curiosity anyway. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ruby/websocket/websocket-1.2.9-r2.ebuild')
-rw-r--r--dev-ruby/websocket/websocket-1.2.9-r2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/websocket/websocket-1.2.9-r2.ebuild b/dev-ruby/websocket/websocket-1.2.9-r2.ebuild
new file mode 100644
index 000000000000..9c9d3b6ac7bf
--- /dev/null
+++ b/dev-ruby/websocket/websocket-1.2.9-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Universal Ruby library to handle WebSocket protocol"
+HOMEPAGE="https://github.com/imanel/websocket-ruby"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE=""
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/rspec-its
+ dev-ruby/webrick
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-default-port.patch
+)