summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-10-27 11:21:49 +0100
committerHans de Graaff <graaff@gentoo.org>2019-10-27 11:22:00 +0100
commit75995818c2a35dae0a9c39fbbd374cfdd54ac9b8 (patch)
tree7dbf6dc9e1d54d6d256d7e0f1894719d8a702a0a /dev-ruby/whole_history_rating/whole_history_rating-0.1.2-r1.ebuild
parentdev-ruby/whole_history_rating: add ruby project as co-maintainer (diff)
downloadgentoo-75995818c2a35dae0a9c39fbbd374cfdd54ac9b8.tar.gz
gentoo-75995818c2a35dae0a9c39fbbd374cfdd54ac9b8.tar.bz2
gentoo-75995818c2a35dae0a9c39fbbd374cfdd54ac9b8.zip
dev-ruby/whole_history_rating: fix various issues
- install documentation - run tests - install default gemspec rather than tinkering with the gemspec file Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/whole_history_rating/whole_history_rating-0.1.2-r1.ebuild')
-rw-r--r--dev-ruby/whole_history_rating/whole_history_rating-0.1.2-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ruby/whole_history_rating/whole_history_rating-0.1.2-r1.ebuild b/dev-ruby/whole_history_rating/whole_history_rating-0.1.2-r1.ebuild
new file mode 100644
index 000000000000..76062cedbcc9
--- /dev/null
+++ b/dev-ruby/whole_history_rating/whole_history_rating-0.1.2-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_TASK_TEST="test_units"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A pure ruby implementation of Remi Coulom's Whole-History Rating algorithm"
+HOMEPAGE="https://github.com/goshrine/${PN}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/test-unit:2
+ )
+"