summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2019-10-25 11:43:31 +0200
committerMichał Górny <mgorny@gentoo.org>2019-10-25 12:00:41 +0200
commit2fe535dde66c10ca6e1dea3ff767db2726f6da46 (patch)
treea55203bb046e4ff8e6fa929e697bcd74e366dfb6 /dev-ruby/whole_history_rating/whole_history_rating-0.1.2.ebuild
parentmedia-gfx/gimp: Add slot-op on libmypaint (diff)
downloadgentoo-2fe535dde66c10ca6e1dea3ff767db2726f6da46.tar.gz
gentoo-2fe535dde66c10ca6e1dea3ff767db2726f6da46.tar.bz2
gentoo-2fe535dde66c10ca6e1dea3ff767db2726f6da46.zip
dev-ruby/whole_history_rating: new package
Package-Manager: Portage-2.3.77, Repoman-2.3.17 Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/13032 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-ruby/whole_history_rating/whole_history_rating-0.1.2.ebuild')
-rw-r--r--dev-ruby/whole_history_rating/whole_history_rating-0.1.2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ruby/whole_history_rating/whole_history_rating-0.1.2.ebuild b/dev-ruby/whole_history_rating/whole_history_rating-0.1.2.ebuild
new file mode 100644
index 000000000000..709e0ffdac87
--- /dev/null
+++ b/dev-ruby/whole_history_rating/whole_history_rating-0.1.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby24 ruby25 ruby26"
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A pure ruby implementation of Remi Coulom's Whole-History Rating algorithm"
+HOMEPAGE="https://github.com/goshrine/${PN}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/test-unit:2
+ )
+"