summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-10-15 06:40:27 +0200
committerHans de Graaff <graaff@gentoo.org>2019-10-15 06:40:27 +0200
commit2d74217c7944a27ac31608ad97bc1a1984905e37 (patch)
tree87e4b54e30803e03298cb1ceac084ac1b6f5fc61 /dev-ruby/will_paginate/will_paginate-3.2.1.ebuild
parentdev-ruby/will_paginate: cleanup (diff)
downloadgentoo-2d74217c7944a27ac31608ad97bc1a1984905e37.tar.gz
gentoo-2d74217c7944a27ac31608ad97bc1a1984905e37.tar.bz2
gentoo-2d74217c7944a27ac31608ad97bc1a1984905e37.zip
dev-ruby/will_paginate: add 3.2.1
Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/will_paginate/will_paginate-3.2.1.ebuild')
-rw-r--r--dev-ruby/will_paginate/will_paginate-3.2.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ruby/will_paginate/will_paginate-3.2.1.ebuild b/dev-ruby/will_paginate/will_paginate-3.2.1.ebuild
new file mode 100644
index 000000000000..3c47cb11bdea
--- /dev/null
+++ b/dev-ruby/will_paginate/will_paginate-3.2.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Most awesome pagination solution for Ruby"
+HOMEPAGE="https://github.com/mislav/will_paginate/"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~amd64 ~x86-macos"
+IUSE=""
+
+all_ruby_prepare() {
+ # Remove tests for unpackaged ORMs
+ rm -f spec/finders/{sequel,mongoid,data_mapper}* || die
+}
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/rails
+ dev-ruby/mocha
+ )"