summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-04-16 08:15:27 +0200
committerHans de Graaff <graaff@gentoo.org>2022-04-16 08:15:27 +0200
commitb90a344ef954d5b981479ddddc937d8fedcaec30 (patch)
treeb70075bdfda26010ed9160ecd99369e9466f6991 /dev-ruby/x25519
parentdev-ruby/zentest: add 4.12.1 (diff)
downloadgentoo-b90a344ef954d5b981479ddddc937d8fedcaec30.tar.gz
gentoo-b90a344ef954d5b981479ddddc937d8fedcaec30.tar.bz2
gentoo-b90a344ef954d5b981479ddddc937d8fedcaec30.zip
dev-ruby/x25519: drop 1.0.8
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/x25519')
-rw-r--r--dev-ruby/x25519/Manifest1
-rw-r--r--dev-ruby/x25519/x25519-1.0.8.ebuild53
2 files changed, 0 insertions, 54 deletions
diff --git a/dev-ruby/x25519/Manifest b/dev-ruby/x25519/Manifest
index 165f3831ce7a..e02da291b442 100644
--- a/dev-ruby/x25519/Manifest
+++ b/dev-ruby/x25519/Manifest
@@ -1,2 +1 @@
-DIST x25519-1.0.8.tar.gz 44313 BLAKE2B 844408f6bb77b55a2ca0222c46d4d09688838d7fc86517636a465da7fb225d9de2f14fda3d38d593f0feddb5e4aeab28ec900766a190759139bf05f6e0e6bd56 SHA512 42a9a2f1c470ea82c070435e4d85317c69fbd6e994f765c46b3aa4b544a5557559ff36194e37100bd8f581711156d185117535aeb3da9f5b6b5523e5a4b347b6
DIST x25519-1.0.9.tar.gz 44042 BLAKE2B 65129fdfc0c40099487da3eacbd91436b625fd1224d58139a09d2ec571cb063f69767d468c89af512b0bef81912786b44b6923afaeb4a14f97a47034b702d848 SHA512 48349960b69f88177b772f431a1751ad190a9d71ebb01e0aced7dcc278a18c2e7cb1dbb621524950685b974f2f63d23039973accf067720ce1b74c5bb1eb4f77
diff --git a/dev-ruby/x25519/x25519-1.0.8.ebuild b/dev-ruby/x25519/x25519-1.0.8.ebuild
deleted file mode 100644
index fb8db353268f..000000000000
--- a/dev-ruby/x25519/x25519-1.0.8.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-USE_RUBY="ruby25 ruby26 ruby27 ruby30"
-
-RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-
-RUBY_FAKEGEM_GEMSPEC="x25519.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Key exchange via the X25519 (Curve25519) Elliptic Curve Diffie-Hellman function"
-HOMEPAGE="https://github.com/crypto-rb/x25519"
-SRC_URI="https://github.com/crypto-rb/x25519/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="$(ver_cut 1)"
-KEYWORDS="amd64 ~arm ppc ppc64 x86"
-IUSE=""
-
-all_ruby_prepare() {
- sed -i -e '/bundler/ s:^:#: ; /coverall/I s:^:#:' spec/spec_helper.rb || die
-
- sed -i -e 's/git ls-files -z/find . -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
-
- # The precomputed implementation only works on amd64
- if ! use amd64 ; then
- sed -i -e '/\(x25519_precomputed\|X25519::Provider::Precomputed\)/ s:^:#:' lib/x25519.rb || die
- rm -f spec/x25519/provider/precomputed_spec.rb || die
- fi
-}
-
-each_ruby_configure() {
- if use amd64 ; then
- ${RUBY} -Cext/x25519_precomputed extconf.rb || die
- fi
-
- ${RUBY} -Cext/x25519_ref10 extconf.rb || die
-}
-
-each_ruby_compile() {
- if use amd64 ; then
- emake V=1 -Cext/x25519_precomputed
- cp ext/x25519_precomputed/x25519_precomputed.so lib/ || die
- fi
-
- emake V=1 -Cext/x25519_ref10
- cp ext/x25519_ref10/x25519_ref10.so lib/ || die
-}