summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-01-01 07:31:16 +0100
committerHans de Graaff <graaff@gentoo.org>2018-01-01 07:31:16 +0100
commitcc9fb16e3dde592514cfc7ea3e475c27d50f2604 (patch)
tree2c6fc087bd2324edf789dde84d37a7da27caf22a /dev-ruby/xpath/xpath-3.0.0.ebuild
parentdev-ruby/xpath: cleanup (diff)
downloadgentoo-cc9fb16e3dde592514cfc7ea3e475c27d50f2604.tar.gz
gentoo-cc9fb16e3dde592514cfc7ea3e475c27d50f2604.tar.bz2
gentoo-cc9fb16e3dde592514cfc7ea3e475c27d50f2604.zip
dev-ruby/xpath: add 3.0.0
Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'dev-ruby/xpath/xpath-3.0.0.ebuild')
-rw-r--r--dev-ruby/xpath/xpath-3.0.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ruby/xpath/xpath-3.0.0.ebuild b/dev-ruby/xpath/xpath-3.0.0.ebuild
new file mode 100644
index 000000000000..a0d9eb988afc
--- /dev/null
+++ b/dev-ruby/xpath/xpath-3.0.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="XPath is a Ruby DSL around a subset of XPath 1.0"
+HOMEPAGE="https://github.com/jnicklas/xpath"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+SLOT="3"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/nokogiri-1.8:0"
+
+all_ruby_prepare() {
+ sed -i -e '/\(bundler\|pry\)/d' spec/spec_helper.rb || die
+}