summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-04-16 08:26:47 +0200
committerHans de Graaff <graaff@gentoo.org>2022-04-16 08:26:55 +0200
commit76aa6f7979922aa1fd3325d20adaa976ea70c16d (patch)
tree65f1942f5316319ca10584a7d221630f0429e294 /dev-ruby/xpath
parentdev-ruby/xml-simple: enable ruby31 (diff)
downloadgentoo-76aa6f7979922aa1fd3325d20adaa976ea70c16d.tar.gz
gentoo-76aa6f7979922aa1fd3325d20adaa976ea70c16d.tar.bz2
gentoo-76aa6f7979922aa1fd3325d20adaa976ea70c16d.zip
dev-ruby/xpath: update EAPI 6 -> 8, add ruby31
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/xpath')
-rw-r--r--dev-ruby/xpath/xpath-3.2.0-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ruby/xpath/xpath-3.2.0-r1.ebuild b/dev-ruby/xpath/xpath-3.2.0-r1.ebuild
new file mode 100644
index 000000000000..497f4840b218
--- /dev/null
+++ b/dev-ruby/xpath/xpath-3.2.0-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="XPath is a Ruby DSL around a subset of XPath 1.0"
+HOMEPAGE="https://github.com/jnicklas/xpath"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+SLOT="3"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/nokogiri-1.8:0"
+
+all_ruby_prepare() {
+ sed -i -e '/\(bundler\|pry\)/d' spec/spec_helper.rb || die
+}