summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-04-02 06:23:38 +0200
committerHans de Graaff <graaff@gentoo.org>2019-04-02 06:23:51 +0200
commit3ea531b84134dc1bb755fb39c9b35ada58ad574f (patch)
treee29613c23f1942a0f781bbd1f587221ed7ef5646 /dev-ruby/yard
parentdev-ruby/yard: cleanup (diff)
downloadgentoo-3ea531b84134dc1bb755fb39c9b35ada58ad574f.tar.gz
gentoo-3ea531b84134dc1bb755fb39c9b35ada58ad574f.tar.bz2
gentoo-3ea531b84134dc1bb755fb39c9b35ada58ad574f.zip
dev-ruby/yard: add 0.9.19
Signed-off-by: Hans de Graaff <graaff@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'dev-ruby/yard')
-rw-r--r--dev-ruby/yard/Manifest1
-rw-r--r--dev-ruby/yard/yard-0.9.19.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-ruby/yard/Manifest b/dev-ruby/yard/Manifest
index f6cce5bc1e24..24a905d5e3e2 100644
--- a/dev-ruby/yard/Manifest
+++ b/dev-ruby/yard/Manifest
@@ -1,2 +1,3 @@
DIST yard-0.9.11-git.tgz 916355 BLAKE2B e9f27fe129cf93c51dbf83f4a7d5745d385252ba63c90f85223f2e9436c22a55aaba296f263072069d39e4beaca3e0830775a8be121c64cdc2a15afd3539a73f SHA512 375a4878e61888cf73aaa06e9300195ae48b9898d8cd639fa796a067e5fa0b89d6ef62d327a388ee83953e80177515f4d8c070042188e3a1e597f48b82b3a72e
DIST yard-0.9.18-git.tgz 919755 BLAKE2B ff0f53234880f1cd2d6ba312542ac560aa7a8cb1864a1bc123f855f2183bc1b5d55316e041e33d57aac18c4784575a1e196fe2113de6280d91a0bb69ade236f5 SHA512 754b2344c630642e191c037ec136976dd812c83051803cf10c4c810d267d405ba609dd5d194fafe4b55c0b123573aeae0139e3994cfacc94560a6ffddd5c6c4f
+DIST yard-0.9.19-git.tgz 920950 BLAKE2B 1f6e6dcde4bb364620256fb48d06d94631f1f1b1e914a187cbce72906731ab7319f818655f20fd4b4d1e43a0864004d2b8e20026feb87189c7261483d1d111d1 SHA512 1656e3b8382a04d48efab7b8f1fd8949691da382cc7d1b7ee3838d6ae3d5372b1668b7e454d6fd3394cb8b152ea4a3c048fadc4c05c0271acb80a052d9f8bd3f
diff --git a/dev-ruby/yard/yard-0.9.19.ebuild b/dev-ruby/yard/yard-0.9.19.ebuild
new file mode 100644
index 000000000000..b026567bee50
--- /dev/null
+++ b/dev-ruby/yard/yard-0.9.19.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby23 ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_TASK_DOC="yard"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_DOCDIR="doc docs"
+
+RUBY_FAKEGEM_EXTRAINSTALL="templates"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Documentation generation tool for the Ruby programming language"
+HOMEPAGE="https://yardoc.org/"
+
+# The gem lakes the gemspec file needed to pass tests.
+SRC_URI="https://github.com/lsegal/yard/archive/v${PV}.tar.gz -> ${P}-git.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "doc? ( || ( dev-ruby/maruku dev-ruby/rdiscount dev-ruby/bluecloth dev-ruby/kramdown ) )"
+
+ruby_add_bdepend "test? ( >=dev-ruby/ruby-gettext-2.3.8 dev-ruby/rack )"
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/ s:^:#:' spec/spec_helper.rb || die
+
+ sed -i -e '/samus/I s:^:#:' Rakefile || die
+
+ # Avoid specs that make assumptions on load ordering that are not
+ # true for us. This may be related to how we install in Gentoo. This
+ # also drops a test requirement on dev-ruby/rack.
+ rm -f spec/cli/server_spec.rb || die
+
+ # Avoid specs that only work with bundler
+ sed -i -e '/#initialize/,/^ end/ s:^:#:' spec/cli/yri_spec.rb || die
+
+ # Avoid redcarpet-specific spec that is not optional
+ sed -i -e '/autolinks URLs/askip "make redcarpet optional"' spec/templates/helpers/html_helper_spec.rb || die
+
+ # Avoid asciidoc-specific spec that is not optional
+ sed -i -e '/\(AsciiDoc specific\|AsciiDoc header\)/askip "skipping asciidoc test"' spec/templates/helpers/html_helper_spec.rb || die
+}