summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/yard
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/yard')
-rw-r--r--dev-ruby/yard/Manifest2
-rw-r--r--dev-ruby/yard/metadata.xml8
-rw-r--r--dev-ruby/yard/yard-0.8.7.3.ebuild38
-rw-r--r--dev-ruby/yard/yard-0.8.7.6.ebuild38
4 files changed, 86 insertions, 0 deletions
diff --git a/dev-ruby/yard/Manifest b/dev-ruby/yard/Manifest
new file mode 100644
index 000000000000..ecdbb19af81e
--- /dev/null
+++ b/dev-ruby/yard/Manifest
@@ -0,0 +1,2 @@
+DIST yard-0.8.7.3-git.tgz 854557 SHA256 d606b5780c8cbe4b4508c34a354f04a5d17609bc0cc07f272c37328e2fca0288 SHA512 96b8a128bacd005e64c3a863ac6cc7377755397c7532b5541809c8a0f5b157cd7433644887823e2d3c4435a0bded59fc2785992fdcf5ebcbf616a4ffd912f6fa WHIRLPOOL 80753671669489b2d6082029ba2b3c24c2aa57e0cdc9a5647e041c60c76f63cb51c33534aab70fb58f26b1ed5fde30a0433dd7f2ef00588273d3c71d1fb799a0
+DIST yard-0.8.7.6-git.tgz 859257 SHA256 ccfadf98936b90e63189f805b6ea9dd6158447b7972f2ddd1578c9898be98a22 SHA512 7f9d4100183e51a2059f01a06a77d9856961390975fd9981b81bf9ea55f047cfd9056c78b5400df277b8230f28990cb421216c4506bbeea797651f37ae2e5db1 WHIRLPOOL a6737f831820dea014a3b093e0c3af43e49cc5815010012bbf1ece2f5ccef7594e4ef95077bd3e97cb5324b79d7ab67d61502052fad498fe0940e2d6a93ec86a
diff --git a/dev-ruby/yard/metadata.xml b/dev-ruby/yard/metadata.xml
new file mode 100644
index 000000000000..0212c7b141ef
--- /dev/null
+++ b/dev-ruby/yard/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">lsegal/yard</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/yard/yard-0.8.7.3.ebuild b/dev-ruby/yard/yard-0.8.7.3.ebuild
new file mode 100644
index 000000000000..1af2c9e9d376
--- /dev/null
+++ b/dev-ruby/yard/yard-0.8.7.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_TASK_DOC="yard"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_DOCDIR="doc docs"
+
+RUBY_FAKEGEM_EXTRAINSTALL="templates"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Documentation generation tool for the Ruby programming language"
+HOMEPAGE="http://yardoc.org/"
+
+# The gem lakes the gemspec file needed to pass tests.
+SRC_URI="https://github.com/lsegal/yard/archive/${PV}.tar.gz -> ${P}-git.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "doc? ( || ( dev-ruby/bluecloth dev-ruby/maruku dev-ruby/rdiscount dev-ruby/kramdown ) )
+ test? ( dev-ruby/rack )"
+
+USE_RUBY="ruby19" ruby_add_bdepend "test? ( >=dev-ruby/ruby-gettext-2.3.8 )"
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/ s:^:#:' spec/spec_helper.rb || die
+ sed -i -e "s/require 'bundler'; rescue LoadError//" spec/cli/server_spec.rb || die
+}
diff --git a/dev-ruby/yard/yard-0.8.7.6.ebuild b/dev-ruby/yard/yard-0.8.7.6.ebuild
new file mode 100644
index 000000000000..aed1613f110d
--- /dev/null
+++ b/dev-ruby/yard/yard-0.8.7.6.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_TASK_DOC="yard"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_DOCDIR="doc docs"
+
+RUBY_FAKEGEM_EXTRAINSTALL="templates"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Documentation generation tool for the Ruby programming language"
+HOMEPAGE="http://yardoc.org/"
+
+# The gem lakes the gemspec file needed to pass tests.
+SRC_URI="https://github.com/lsegal/yard/archive/v${PV}.tar.gz -> ${P}-git.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "doc? ( || ( dev-ruby/maruku dev-ruby/rdiscount dev-ruby/bluecloth dev-ruby/kramdown ) )
+ test? ( dev-ruby/rack )"
+
+USE_RUBY="ruby19" ruby_add_bdepend "test? ( >=dev-ruby/ruby-gettext-2.3.8 )"
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/ s:^:#:' spec/spec_helper.rb || die
+ sed -i -e "s/require 'bundler'; rescue LoadError//" spec/cli/server_spec.rb || die
+}