summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-12-29 07:52:49 +0100
committerHans de Graaff <graaff@gentoo.org>2020-12-29 07:52:58 +0100
commit5d3e3b8d5f550eceb31cc15ba4f43d76e127f432 (patch)
tree6f9d9fa746c878115227b06f75e19a0702c64130 /dev-ruby/yard
parentdev-ruby/minitest-power_assert: add ruby30 (diff)
downloadgentoo-5d3e3b8d5f550eceb31cc15ba4f43d76e127f432.tar.gz
gentoo-5d3e3b8d5f550eceb31cc15ba4f43d76e127f432.tar.bz2
gentoo-5d3e3b8d5f550eceb31cc15ba4f43d76e127f432.zip
dev-ruby/yard: add 0.9.26
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/yard')
-rw-r--r--dev-ruby/yard/Manifest1
-rw-r--r--dev-ruby/yard/yard-0.9.26.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-ruby/yard/Manifest b/dev-ruby/yard/Manifest
index 51458f0aff12..4e18ebf375a7 100644
--- a/dev-ruby/yard/Manifest
+++ b/dev-ruby/yard/Manifest
@@ -1,2 +1,3 @@
DIST yard-0.9.20-git.tgz 921130 BLAKE2B 37b1b2524147a1a8cb36c3835cce4e7666e2c8d3d5c187eb402000fb251df64111c4f104957ac9d28bd0e8d9328eb1d97571337ae54479626dcaab3cf07625a6 SHA512 b7e035a3598c8ef32fcbaae57254c0fb0cba875606b434571da2ef754f3171b5c42a4b3a45bd4bf41bce368f6fb7e448567f601a9cab5fbdae695bbec1b73608
DIST yard-0.9.25-git.tgz 930253 BLAKE2B 35531a7e90ab99bad8d236ea4774a8aebc50eff5d78f60e2dfea8edb2af965dc60e8c02f8a1f95166e80d6f1ce21aca051b92b2511b88a7d87d2cc90e58bcd17 SHA512 855bf05ce45a965d534191b036831ec1cedc848e21196ed93cc7984d744328d9d5ba39664b4539a707a1556984990360cd27e085b830501ac8d72c6cebb3e689
+DIST yard-0.9.26-git.tgz 930901 BLAKE2B 19baaefc54269bbc7eee053b42f2be85644a062cbf55b0fafb63748876aad3a3143767855f4ee7b10a1ae814110a6cf63c01e4055e054aeb31bf8512e793d80d SHA512 0f70a089d5e5ba33e326b0ae0cc84a2cacfc5a3f3080545d5fc5bb324dedbbbf65116cc9412b3496c09b2b6c15514e854a741a1fd7e2ae782804d6e4ac28fcd9
diff --git a/dev-ruby/yard/yard-0.9.26.ebuild b/dev-ruby/yard/yard-0.9.26.ebuild
new file mode 100644
index 000000000000..2650101cbad8
--- /dev/null
+++ b/dev-ruby/yard/yard-0.9.26.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_TASK_DOC="yard"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_DOCDIR="doc docs"
+
+RUBY_FAKEGEM_EXTRAINSTALL="templates"
+
+RUBY_FAKEGEM_GEMSPEC="yard.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Documentation generation tool for the Ruby programming language"
+HOMEPAGE="https://yardoc.org/"
+
+# The gem lakes the gemspec file needed to pass tests.
+SRC_URI="https://github.com/lsegal/yard/archive/v${PV}.tar.gz -> ${P}-git.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "doc? ( || ( dev-ruby/maruku dev-ruby/rdiscount dev-ruby/kramdown ) )"
+
+ruby_add_bdepend "test? ( dev-ruby/rack )"
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/ s:^:#:' spec/spec_helper.rb || die
+
+ sed -i -e '/samus/I s:^:#:' Rakefile || die
+
+ sed -i -e 's/git ls-files/find/' ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ # Avoid specs that make assumptions on load ordering that are not
+ # true for us. This may be related to how we install in Gentoo. This
+ # also drops a test requirement on dev-ruby/rack.
+ rm -f spec/cli/server_spec.rb || die
+
+ # Avoid specs that only work with bundler
+ sed -i -e '/#initialize/,/^ end/ s:^:#:' spec/cli/yri_spec.rb || die
+ sed -e '/overwrites options with data in/askip "wrong assumptions on file access"' \
+ -e '/loads any gem plugins starting with/askip "wrong assumptions on file access"' \
+ -i spec/config_spec.rb || die
+
+ # Avoid redcarpet-specific spec that is not optional
+ sed -i -e '/autolinks URLs/askip "make redcarpet optional"' spec/templates/helpers/html_helper_spec.rb || die
+
+ # Avoid asciidoc-specific spec that is not optional
+ sed -i -e '/\(AsciiDoc specific\|AsciiDoc header\)/askip "skipping asciidoc test"' spec/templates/helpers/html_helper_spec.rb || die
+}