summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-10-22 06:21:32 +0200
committerHans de Graaff <graaff@gentoo.org>2022-10-22 06:21:32 +0200
commit0ac194d3ccc9653768e0ae98ca404c96121bb12a (patch)
tree2110469539c5a00b0014e44795ac9758b3cadb3f /dev-ruby
parentdev-ruby/excon: stabilize 0.92.4 for amd64 (diff)
downloadgentoo-0ac194d3ccc9653768e0ae98ca404c96121bb12a.tar.gz
gentoo-0ac194d3ccc9653768e0ae98ca404c96121bb12a.tar.bz2
gentoo-0ac194d3ccc9653768e0ae98ca404c96121bb12a.zip
dev-ruby/rack-protection: add 3.0.2
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/rack-protection/Manifest1
-rw-r--r--dev-ruby/rack-protection/rack-protection-3.0.2.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-ruby/rack-protection/Manifest b/dev-ruby/rack-protection/Manifest
index 606fbe1aea17..d9636c2171be 100644
--- a/dev-ruby/rack-protection/Manifest
+++ b/dev-ruby/rack-protection/Manifest
@@ -2,3 +2,4 @@ DIST rack-protection-2.2.0.gem 17408 BLAKE2B d9d5d8e2473b6354dd61cfc338a05932a2c
DIST rack-protection-2.2.1.gem 17408 BLAKE2B 21ecf95a27ab08b2e89369cfaffff43192c2ca5bb74afe7a91041e5fb9f2479a625ca2fcc59fc2f3eb208f17a3456dffd14095d25f8a0ed331972f6f987dace6 SHA512 595dc7ff7deb63130f966a12849750900319356f29948e9cca1e1aebe168bad77de624dd280a1b804ad6a2d44daedfcb352777ca724e9fde2a5de02ead472734
DIST rack-protection-2.2.2.gem 17408 BLAKE2B d67384374afa29712742531bff0cca78be96f80dd316d4e5929cb2751152bc0d73f8ede4430aa50a2e114b872845f11ca8debe93eaa1a7a63e05daae697c2e7d SHA512 6bc7694daebcc2fb585b303aa059e82db94c142a82d0e951e0dd99388074449c989d41c3aa05882a150776e28d0394f78d0b063e564e7eda7aea14d496eef0fb
DIST rack-protection-3.0.1.gem 20480 BLAKE2B 102fff6298dbbb766313687b6f3653c60d055c654922e108c0e5eab1364858adf83a800c66f0800ef8a48997884e4b0c16ad1a70c2d00d657fdbcdb929c18bbc SHA512 730cb4fa67e86ee79043e706c4a011f1f4fad8902d27ed25a14e03c7acf7644db9e8685bb6248d9511d32d55a1f13eb548cd9471958b69bf88c4c371fcc1a8df
+DIST rack-protection-3.0.2.gem 20480 BLAKE2B 95c951c6995ac4e69bb6aca85ff0c8a86793466db84e149ef6d287fb479fe49bc3708d0bc71ca656c4bb79b069d3b01139fab04756bc68051eda90db29f506a4 SHA512 54603e8ba22f1b359e5ffe82a3ee99a31a26e5dedd1e46edd4591ca416a1f241dc37ce2b6da25262a9cf9027b0e8687bd23c6dcbea0197131ca33088cbfd0280
diff --git a/dev-ruby/rack-protection/rack-protection-3.0.2.ebuild b/dev-ruby/rack-protection/rack-protection-3.0.2.ebuild
new file mode 100644
index 000000000000..d31bdbd997d7
--- /dev/null
+++ b/dev-ruby/rack-protection/rack-protection-3.0.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby27 ruby30 ruby31"
+
+# There are no specs in the gem and the source cannot be downloaded separately.
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="This gem protects against typical web attacks"
+HOMEPAGE="https://github.com/rkh/rack-protection"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/rack:*"
+
+# ruby_add_bdepend "test? ( dev-ruby/rack-test )"