summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-04-22 08:19:43 +0200
committerHans de Graaff <graaff@gentoo.org>2022-04-22 08:55:52 +0200
commit11329c4fabee79effb944a6328ba4d890f69b0a0 (patch)
treed846a0a31f0c11d585ead41e4a9a7d8cffa29bff /dev-ruby
parentdev-ruby/sourcemap: enable ruby31 (diff)
downloadgentoo-11329c4fabee79effb944a6328ba4d890f69b0a0.tar.gz
gentoo-11329c4fabee79effb944a6328ba4d890f69b0a0.tar.bz2
gentoo-11329c4fabee79effb944a6328ba4d890f69b0a0.zip
dev-ruby/ruby-ole: update EAPI 6 -> 8
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/ruby-ole/ruby-ole-1.2.12.2-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/ruby-ole/ruby-ole-1.2.12.2-r1.ebuild b/dev-ruby/ruby-ole/ruby-ole-1.2.12.2-r1.ebuild
new file mode 100644
index 000000000000..ccc0514b0eb5
--- /dev/null
+++ b/dev-ruby/ruby-ole/ruby-ole-1.2.12.2-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30 ruby31"
+
+# Avoid the complexity of the "rake" recipe and run testrb-2 manually.
+RUBY_FAKEGEM_RECIPE_TEST=none
+
+# Same thing for the docs whose rake target just calls rdoc.
+RUBY_FAKEGEM_RECIPE_DOC=rdoc
+RUBY_FAKEGEM_EXTRADOC="ChangeLog README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby library for easy read/write access to OLE compound documents"
+HOMEPAGE="https://github.com/aquasync/ruby-ole"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/test-unit:2 )"
+
+each_ruby_test() {
+ ruby-ng_testrb-2 --pattern='test.*\.rb' test/
+}