summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-05-14 10:30:14 +0200
committerHans de Graaff <graaff@gentoo.org>2022-05-14 10:32:50 +0200
commit136ae68145f19733ea626f08747f263fa5a6600a (patch)
treeb182f9def5befab55b4b317036cf13a9e00a90be /dev-ruby
parentapp-arch/bzip3: fix HOMEPAGE, LICENSE (diff)
downloadgentoo-136ae68145f19733ea626f08747f263fa5a6600a.tar.gz
gentoo-136ae68145f19733ea626f08747f263fa5a6600a.tar.bz2
gentoo-136ae68145f19733ea626f08747f263fa5a6600a.zip
dev-ruby/activesupport: add 7.0.3
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/activesupport/Manifest1
-rw-r--r--dev-ruby/activesupport/activesupport-7.0.3.ebuild73
2 files changed, 74 insertions, 0 deletions
diff --git a/dev-ruby/activesupport/Manifest b/dev-ruby/activesupport/Manifest
index 27726400c822..2ca4cdbed1ae 100644
--- a/dev-ruby/activesupport/Manifest
+++ b/dev-ruby/activesupport/Manifest
@@ -12,3 +12,4 @@ DIST rails-6.1.6.tgz 10993299 BLAKE2B 98a80cbefc1aafba68a22b60d3df6b81ab1e8247a7
DIST rails-7.0.2.2.tgz 11034626 BLAKE2B 388a27b5434f1ae062cb7c3a68881a885dd659dbd9e86c4d36e0cb29c493f127fb9cbdf0f9ce7dea5a715ddbcd7a3bff5e2de3adb2e278c8bf63c2473d1e4b6d SHA512 e7863f1e072d266b8df1abb8abf6b141bad74ef77fe5dbcd66e7603e2ebf386520e4fd8f337edb5f5a6bd5607fbaa146823cbe6980fd7864e3934a7c9d382e3d
DIST rails-7.0.2.3.tgz 11037677 BLAKE2B b4d0ac3d2c56d262beca4f5ba1659a67526c01321dc00ef8392a11c6fbc7614e3c02cf02ffcbb5ed1911005c1be0c0741e225f45c5946fc9102629c5ba5d32ab SHA512 4dcbe65ce1bad803dd04be61918f1ca893529705a8336a0c09b0193eb453319fc42ed0e2dca6ff5cb56f0c2bc5ab03c9d9f479101904ad1a746980cd887798d4
DIST rails-7.0.2.4.tgz 11014591 BLAKE2B 4a678dddca134769a40d73a6652a6aa273456288c19ddbe7611ae40a14860abf77226ab351ead92647fb471751521377c51cafae40383198ff3d3477bc257b55 SHA512 948cf58dd6ac517fb4b1e63c3a1dbfcf2405fd224ea150cb92f5805939d3a458ad26e139b1c6069cc587c01f15694be14e119ee56769a611e6b6eaa0eae5a68c
+DIST rails-7.0.3.tgz 11021571 BLAKE2B 00385233279a773221ae8a1e75354d404d033206089323c53c0e81a134941151aab4578218438dd4193b2c00a0cd4ef1eb6a758502a51d403bddb11915ed9eb7 SHA512 366eaae24b0e147c9e33179c10c0a22f7c7671551222e329120749f04077bd344fabf55e90af041322787bf3063add927c7fd34758ae8764e00f8d8edba388ef
diff --git a/dev-ruby/activesupport/activesupport-7.0.3.ebuild b/dev-ruby/activesupport/activesupport-7.0.3.ebuild
new file mode 100644
index 000000000000..111aab567962
--- /dev/null
+++ b/dev-ruby/activesupport/activesupport-7.0.3.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activesupport.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Utility Classes and Extension to the Standard Library"
+HOMEPAGE="https://github.com/rails/rails"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ >=dev-ruby/concurrent-ruby-1.0.2:1
+ >=dev-ruby/i18n-1.6:1
+ dev-ruby/tzinfo:2
+ >=dev-ruby/minitest-5.1:5
+"
+
+# memcache-client, nokogiri, builder, and redis are not strictly needed,
+# but there are tests using this code.
+ruby_add_bdepend "test? (
+ >=dev-ruby/dalli-3.0.1
+ dev-ruby/connection_pool
+ >=dev-ruby/nokogiri-1.8.1
+ >=dev-ruby/builder-3.1.0
+ >=dev-ruby/listen-3.3:3
+ dev-ruby/rack
+ dev-ruby/rexml
+ dev-ruby/mocha
+ )"
+
+all_ruby_prepare() {
+ # Set the secure permissions that tests expect.
+ chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
+
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ sed -i -e "/\(system_timer\|pg\|execjs\|jquery-rails\|mysql\|journey\|ruby-prof\|stackprof\|benchmark-ips\|turbolinks\|coffee-rails\|debugger\|sprockets-rails\|bcrypt\|uglifier\|minitest\|sprockets\|stackprof\|rack-cache\|sqlite\|websocket-client-simple\|\libxml-ruby\|bootsnap\|aws-sdk\|webmock\|capybara\|sass-rails\|selenium-webdriver\|webpacker\|webrick\|propshaft\)/ s:^:#:" \
+ -e '/stimulus-rails/,/tailwindcss-rails/ s:^:#:' \
+ -e '/group :\(doc\|rubocop\|job\|cable\|storage\|ujs\|test\|view\) do/,/^end/ s:^:#:' \
+ -e 's/gemspec/gemspec path: "activesupport"/' \
+ -e '5igem "builder"; gem "rack"' ../Gemfile || die
+ rm ../Gemfile.lock || die
+
+ # Avoid test that depends on timezone
+ sed -i -e '/test_implicit_coercion/,/^ end/ s:^:#:' test/core_ext/duration_test.rb || die
+
+ # Avoid tests that seem to trigger race conditions.
+ rm -f test/evented_file_update_checker_test.rb || die
+
+ # Avoid test that generates filename that is too long
+ sed -i -e '/test_filename_max_size/askip "gentoo"' test/cache/stores/file_store_test.rb || die
+
+ # Avoid tests requiring a live redis running
+ rm -f test/cache/stores/redis_cache_store_test.rb || die
+ sed -i -e '/cache_stores:redis/ s:^:#:' Rakefile || die
+ sed -i -e '/test_redis_cache_store/askip "lacking keywords"' test/cache/cache_store_setting_test.rb || die
+}