summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-04-03 06:26:48 +0200
committerHans de Graaff <graaff@gentoo.org>2020-04-03 06:28:56 +0200
commit14c1f54657a25b8b55f2c2d2e09f994edb9669aa (patch)
tree54c63590cd79cb5a92951dbafa51cddd48bfa9e8 /dev-ruby
parentnet-vpn/ocserv: remove lz4 USE flag description (diff)
downloadgentoo-14c1f54657a25b8b55f2c2d2e09f994edb9669aa.tar.gz
gentoo-14c1f54657a25b8b55f2c2d2e09f994edb9669aa.tar.bz2
gentoo-14c1f54657a25b8b55f2c2d2e09f994edb9669aa.zip
dev-ruby/tzinfo: add 2.0.2
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/tzinfo/Manifest1
-rw-r--r--dev-ruby/tzinfo/tzinfo-2.0.2.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-ruby/tzinfo/Manifest b/dev-ruby/tzinfo/Manifest
index 4b28967a91bb..0e250cf783a7 100644
--- a/dev-ruby/tzinfo/Manifest
+++ b/dev-ruby/tzinfo/Manifest
@@ -2,3 +2,4 @@ DIST tzinfo-1.2.5.gem 153600 BLAKE2B 3df5625c61eabf94bb457381ac7d0cdebd5b55da3bb
DIST tzinfo-1.2.6.gem 156160 BLAKE2B 5e1459dc1a22e22e585f29f2ee71e5306017a04a75233f7cfdf0e54a3086b69e6d216c73f81b358e2b8aaa6898d3826f25c860f88439ed9181811254e7823943 SHA512 2ab5bdcb0c2d3b0dac801533235add47a9aea3f5c550874b5b66498c4ea065a2af826cd02334ce0841ebab4a543f9259433a712f64b2b7d858751854b8003b2b
DIST tzinfo-2.0.0.tar.gz 210379 BLAKE2B e3b8b7763dbe26ce58b1a1672d11c412f362910d695c321e51a9c28f1e742db34aa7c066827d7a4634e4a1f7824205007b66191cbeba7776dbc6cac1c9f144ca SHA512 cdc3393af8402dbde491f4547a1b169d90bcf7228c89b64f104538223fcb8f5cf8f7861ae1e11a723b213de7ab09fe31fc04ed9f275f80fe2929f0279d830679
DIST tzinfo-2.0.1.tar.gz 212477 BLAKE2B 95a7ed460054d258485e24e63140853218ba00a7e3afc0c0ee2be5c91ee66588aec663a17d50dab7237b0091d0f423a845c474b18873a2a8153db2745f8fc1a7 SHA512 9cfd0a076aba5e7ae2f519374a6154a62e3ec71eaeb2d5a31bb07e3e26b44c4e01fce8cb385e0da9c565e0e408a0a7f204ac666baa7a9d6f3a592f2218ef99b6
+DIST tzinfo-2.0.2.tar.gz 213501 BLAKE2B 7886ba84257b85104073445d0948fd5f58985fa0f5f85c1ec15978c6f497fffb9bd997a0bae1313d697115c487c069dda1b7e5dd4ec2c7580951d0a8ddf8d623 SHA512 a0c71dd9299e84bd71a91858ba8c12a0ba00c625219da1172d5cd1dfd35318ce8a83e59f45489c2ed5161761e1c39834ba63dbfa189acb100ba37ceae842668d
diff --git a/dev-ruby/tzinfo/tzinfo-2.0.2.ebuild b/dev-ruby/tzinfo/tzinfo-2.0.2.ebuild
new file mode 100644
index 000000000000..3e62e9f03174
--- /dev/null
+++ b/dev-ruby/tzinfo/tzinfo-2.0.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby24 ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_TASK_TEST="test_zoneinfo"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="tzinfo.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Daylight-savings aware timezone library"
+HOMEPAGE="https://tzinfo.github.io/"
+SRC_URI="https://github.com/tzinfo/tzinfo/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="sys-libs/timezone-data"
+DEPEND="test? ( sys-libs/timezone-data )"
+
+ruby_add_rdepend "dev-ruby/concurrent-ruby:1"
+ruby_add_bdepend "test? ( dev-ruby/bundler dev-ruby/minitest:5 )"
+
+all_ruby_prepare() {
+ # Set the secure permissions that tests expect.
+ chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
+
+ # Skip safe tests since we cannot guarantee the correct permissions
+ # on directories for it to pass.
+ sed -e '/safe_test/askip "does not pass in gentoo test environment"' -i test/test_utils.rb || die
+
+ # Loosen test dependencies
+ sed -e '/rake/ s/12.2.1/12.2/' \
+ -e '/simplecov/d' \
+ -i Gemfile || die
+ sed -e '/TEST_COVERAGE/d' -i Rakefile || die
+}
+
+each_ruby_test() {
+ ${RUBY} -S bundle exec rake test || die
+}