summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-07-20 07:03:27 +0200
committerHans de Graaff <graaff@gentoo.org>2016-07-20 07:03:27 +0200
commit15ae366c8052540c8689fd4f99abd262617eb535 (patch)
treecb906ad8d8701d4043b5004445b5cf7c7316b7aa /dev-ruby
parentdev-ruby/flexmock: add 2.2.1 (diff)
downloadgentoo-15ae366c8052540c8689fd4f99abd262617eb535.tar.gz
gentoo-15ae366c8052540c8689fd4f99abd262617eb535.tar.bz2
gentoo-15ae366c8052540c8689fd4f99abd262617eb535.zip
dev-ruby/libxml: add 2.9.0
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/libxml/Manifest1
-rw-r--r--dev-ruby/libxml/libxml-2.9.0.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-ruby/libxml/Manifest b/dev-ruby/libxml/Manifest
index dc226f3d4fb5..fc2c25843521 100644
--- a/dev-ruby/libxml/Manifest
+++ b/dev-ruby/libxml/Manifest
@@ -1 +1,2 @@
DIST libxml-ruby-2.8.0.gem 261120 SHA256 0bd2780afaaf944d38786999d929a4fd37eb30922c404301b86dee94c9c512b6 SHA512 085670e0d343d47085d03d7d95a94498e7be049fbab5e60f1c5f43f9fc41222fe96315de7d5b12b221a3c866d0c178dbfbe2e717a206cce8c4471a2b3ddb9c42 WHIRLPOOL bae7fe3e885b35c58e314cf84ecf0f09abb754e4d41e047b101f20fc2d62f7695e328f8cc07f91d473de87ceb82c2a54d37ea4cb03c421897a5d539605883400
+DIST libxml-ruby-2.9.0.gem 262144 SHA256 e25a6278aaca2376ec0cc9e93a034a25d95af1102590abdbfce786d5c6612ddf SHA512 06ad42ce68c16715fc92a41439c3c27b49fc25b4f8829fac0a27f860d6c3df9a4cb964f1b4677d7587d31c0e5542c4d1c1c25ae3bcfcec889015618d22f6ff3c WHIRLPOOL e656ac449cd893325378b5af1d1108c8b2fa53e79b9000891785ffe5800a067f961c162699d1c6fab585dd8ba475b4b97898ee1ff2d2cf254c10a965504122c8
diff --git a/dev-ruby/libxml/libxml-2.9.0.ebuild b/dev-ruby/libxml/libxml-2.9.0.ebuild
new file mode 100644
index 000000000000..2bab503b1e9b
--- /dev/null
+++ b/dev-ruby/libxml/libxml-2.9.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_NAME="libxml-ruby"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc HISTORY"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby libxml with a user friendly API, akin to REXML"
+HOMEPAGE="https://github.com/xml4r/libxml-ruby"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="${RDEPEND} dev-libs/libxml2"
+DEPEND="${DEPEND} dev-libs/libxml2"
+
+ruby_add_bdepend "doc? ( dev-ruby/rdoc )"
+
+all_ruby_prepare() {
+ # Remove grancher tasks only needed for publishing the website
+ sed -i -e '/grancher/d' -e '/Grancher/,$d' Rakefile || die
+
+ # We don't have the hanna template available.
+ sed -i -e 's/hanna/rake/' Rakefile || die
+
+ # Remove rake-compiler bits since we don't use it
+ sed -i -e '/extensiontask/d' -e '/ExtensionTask/,/end/d' -e '/GemPackageTask/,/end/d' Rakefile || die
+
+ # Avoid test that fails intermittently
+ sed -i -e '/test_get_handler/,/^ end/ s:^:#:' test/tc_error.rb || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -C ext/libxml extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake -C ext/libxml V=1
+ cp ext/libxml/libxml_ruby.so lib/ || die
+}