summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-05-31 06:22:16 +0200
committerHans de Graaff <graaff@gentoo.org>2017-05-31 06:24:20 +0200
commit207a26e68f8f3c6c2931d8a24c76d674c1d49312 (patch)
treef3edefd9deaba3842a2b0cf955710d7bd576ff4a /dev-ruby
parentremove masked dev-ruby/ruby-inifile (diff)
downloadgentoo-207a26e68f8f3c6c2931d8a24c76d674c1d49312.tar.gz
gentoo-207a26e68f8f3c6c2931d8a24c76d674c1d49312.tar.bz2
gentoo-207a26e68f8f3c6c2931d8a24c76d674c1d49312.zip
remove masked dev-ruby/ruby-tcpwrap
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/ruby-tcpwrap/Manifest1
-rw-r--r--dev-ruby/ruby-tcpwrap/files/ruby-tcpwrap-0.6-ruby19.patch83
-rw-r--r--dev-ruby/ruby-tcpwrap/metadata.xml8
-rw-r--r--dev-ruby/ruby-tcpwrap/ruby-tcpwrap-0.6-r3.ebuild54
4 files changed, 0 insertions, 146 deletions
diff --git a/dev-ruby/ruby-tcpwrap/Manifest b/dev-ruby/ruby-tcpwrap/Manifest
deleted file mode 100644
index ef16c4cf22ab..000000000000
--- a/dev-ruby/ruby-tcpwrap/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST ruby-tcpwrap-0.6.tar.gz 4504 SHA256 b896dc36d41951ba5e3f769d1ad5a246b1f559d58f6435966ebe1d4d369996ea SHA512 51385f6a1cbcb18ce5866d5c2edd3388891835781f66d22558ad72e9dbb4639f376b5cae8a2890289b4d2cfbd4fb4f42d45c13b596372601ff57b6f1638ca6c1 WHIRLPOOL eaa402a06726fd0bd125fbb49af5c82676cbef62a736d15a343c63f6f2deedc485a548cf2bf76759f3de7b192769f80f1715df7a65cc35ea18c2c4176a6131e5
diff --git a/dev-ruby/ruby-tcpwrap/files/ruby-tcpwrap-0.6-ruby19.patch b/dev-ruby/ruby-tcpwrap/files/ruby-tcpwrap-0.6-ruby19.patch
deleted file mode 100644
index 3f30d592a22c..000000000000
--- a/dev-ruby/ruby-tcpwrap/files/ruby-tcpwrap-0.6-ruby19.patch
+++ /dev/null
@@ -1,83 +0,0 @@
-diff -Naur ruby-tcpwrap.orig//tcpwrap.c ruby-tcpwrap//tcpwrap.c
---- ruby-tcpwrap.orig//tcpwrap.c 2003-08-20 12:30:10.000000000 +0900
-+++ ruby-tcpwrap//tcpwrap.c 2010-05-28 08:08:49.000000000 +0900
-@@ -25,7 +25,11 @@
- */
-
- #include "ruby.h"
-+#ifdef HAVE_RUBY_IO_H
-+#include "ruby/io.h"
-+#else
- #include "rubyio.h"
-+#endif
- #include <sys/types.h>
- #include <sys/socket.h>
- #include <netinet/in.h>
-@@ -46,6 +50,10 @@
-
- #define DEFAULT_RFC1413_QUERY_TIMEOUT 30
-
-+#ifndef RSTRING_PTR
-+#define RSTRING_PTR(str) RSTRING(str)->ptr
-+#endif
-+
- int allow_severity = 0;
- int deny_severity = 0;
-
-@@ -101,7 +109,7 @@
- tcp_wrapper_t *tcpd;
- VALUE sock;
- int sockfd;
-- OpenFile *fptr;
-+ rb_io_t *fptr;
- struct sockaddr_storage addr;
- char client_name[NI_MAXHOST] = STRING_UNKNOWN;
- char client_addr[NI_MAXHOST] = STRING_UNKNOWN;
-@@ -113,7 +121,11 @@
- again:
- sock = rb_funcall(tcpd->server, rb_intern("accept"), 0);
- GetOpenFile(sock, fptr);
-+#ifdef HAVE_RUBY_IO_H
-+ sockfd = fileno(fptr->fd);
-+#else
- sockfd = fileno(fptr->f);
-+#endif
- if (getpeername(sockfd, (struct sockaddr*) &addr, &len) < 0)
- rb_sys_fail("getpeername(2)");
- error = getnameinfo((struct sockaddr*) &addr, len,
-@@ -132,7 +144,7 @@
- if (tcpd->ident_lookup)
- client_user = ident_id(sockfd, tcpd->ident_timeout);
- #endif
-- if (!hosts_ctl(RSTRING(tcpd->daemon)->ptr,
-+ if (!hosts_ctl(RSTRING_PTR(tcpd->daemon),
- client_name,
- client_addr,
- (client_user == NULL) ? STRING_UNKNOWN : client_user)) {
-@@ -157,7 +169,7 @@
- static char hosts_allow[MAXPATHLEN];
-
- Check_SafeStr(s);
-- snprintf(hosts_allow, sizeof(hosts_allow), "%s", RSTRING(s)->ptr);
-+ snprintf(hosts_allow, sizeof(hosts_allow), "%s", RSTRING_PTR(s));
- if(access(hosts_allow, R_OK) < 0)
- rb_warning("cannot read %s", hosts_allow);
- hosts_allow_table = hosts_allow;
-@@ -177,7 +189,7 @@
- static char hosts_deny[MAXPATHLEN];
-
- Check_SafeStr(s);
-- snprintf(hosts_deny, sizeof(hosts_deny), "%s", RSTRING(s)->ptr);
-+ snprintf(hosts_deny, sizeof(hosts_deny), "%s", RSTRING_PTR(s));
- if(access(hosts_deny, R_OK) < 0)
- rb_warning("cannot read %s", hosts_deny);
- hosts_deny_table = hosts_deny;
-@@ -196,7 +208,7 @@
- {
- if(NIL_P(s)) return STRING_UNKNOWN;
- Check_Type(s, T_STRING);
-- return RSTRING(s)->ptr;
-+ return RSTRING_PTR(s);
- }
-
- static VALUE
diff --git a/dev-ruby/ruby-tcpwrap/metadata.xml b/dev-ruby/ruby-tcpwrap/metadata.xml
deleted file mode 100644
index 28ab0c15f206..000000000000
--- a/dev-ruby/ruby-tcpwrap/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="project">
- <email>ruby@gentoo.org</email>
- <name>Gentoo Ruby Project</name>
-</maintainer>
-</pkgmetadata>
diff --git a/dev-ruby/ruby-tcpwrap/ruby-tcpwrap-0.6-r3.ebuild b/dev-ruby/ruby-tcpwrap/ruby-tcpwrap-0.6-r3.ebuild
deleted file mode 100644
index a03a32e26ebc..000000000000
--- a/dev-ruby/ruby-tcpwrap/ruby-tcpwrap-0.6-r3.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-# ruby22 -> Does not compile
-USE_RUBY="ruby21"
-
-inherit ruby-ng
-
-DESCRIPTION="A TCP wrappers library for Ruby"
-HOMEPAGE="http://raa.ruby-lang.org/list.rhtml?name=ruby-tcpwrap"
-SRC_URI="http://shugo.net/archive/ruby-tcpwrap/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~hppa ~mips ~ppc x86"
-IUSE=""
-
-DEPEND+=" net-libs/libident
- sys-apps/tcp-wrappers"
-
-RDEPEND+=" net-libs/libident
- sys-apps/tcp-wrappers"
-
-RUBY_S="${PN}"
-RUBY_PATCHES=( "${P}-ruby19.patch" )
-
-each_ruby_configure() {
- ${RUBY} extconf.rb || die "extconf.rb failed"
-}
-
-each_ruby_compile() {
- # We have injected --no-undefined in Ruby as a safety precaution
- # against broken ebuilds, but the Ruby-Gnome bindings
- # unfortunately rely on the lazy load of other extensions; see bug
- # #320545.
- find . -name Makefile -print0 | xargs -0 \
- sed -i -e 's:-Wl,--no-undefined ::' || die "--no-undefined removal failed"
-
- emake V=1
-}
-
-each_ruby_install() {
- emake DESTDIR="${D}" install V=1
-}
-
-all_ruby_install() {
- dodoc README*
- dohtml doc/*
-
- docinto sample
- dodoc sample/*
-}