summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-05-13 08:02:03 +0200
committerHans de Graaff <graaff@gentoo.org>2021-05-13 08:02:03 +0200
commit20ac5f94df4a36d4dafa1ae580f21967eb3f9ffc (patch)
tree845ba3277583a435033da04bc7f2e8da0884f9c1 /dev-ruby
parentdev-ruby/hashdiff: amd64 stable (diff)
downloadgentoo-20ac5f94df4a36d4dafa1ae580f21967eb3f9ffc.tar.gz
gentoo-20ac5f94df4a36d4dafa1ae580f21967eb3f9ffc.tar.bz2
gentoo-20ac5f94df4a36d4dafa1ae580f21967eb3f9ffc.zip
dev-ruby/shoulda-context: add ruby30
Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/shoulda-context/shoulda-context-1.2.2-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-ruby/shoulda-context/shoulda-context-1.2.2-r1.ebuild b/dev-ruby/shoulda-context/shoulda-context-1.2.2-r1.ebuild
new file mode 100644
index 000000000000..11edf3357612
--- /dev/null
+++ b/dev-ruby/shoulda-context/shoulda-context-1.2.2-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby25 ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_EXTRADOC="CONTRIBUTING.md README.md"
+
+RUBY_FAKEGEM_EXTRAINSTALL="init.rb rails tasks"
+
+# Don't install the conversion script to avoid collisions with older
+# shoulda.
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Context framework extracted from Shoulda"
+HOMEPAGE="https://github.com/thoughtbot/shoulda-context"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc test"
+
+ruby_add_bdepend "test? ( dev-ruby/test-unit:2
+ <dev-ruby/mocha-1 )"
+
+all_ruby_prepare() {
+ sed -i -e "1igem 'mocha', '~>0.10'\n" test/test_helper.rb || die
+}
+
+each_ruby_test() {
+ BUNDLE_GEMFILE=x ruby-ng_testrb-2 -Itest test/shoulda/*_test.rb || die
+}