summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-02-03 15:54:27 +0100
committerHans de Graaff <graaff@gentoo.org>2023-02-04 08:07:52 +0100
commit2ab003050d466afe42884f2a2a7ca881b470be48 (patch)
treeb159201795a710825cddeebe8e9f96fdb4c95d53 /dev-ruby
parentdev-ruby/sinatra-partial: fix tests with rack 3 present (diff)
downloadgentoo-2ab003050d466afe42884f2a2a7ca881b470be48.tar.gz
gentoo-2ab003050d466afe42884f2a2a7ca881b470be48.tar.bz2
gentoo-2ab003050d466afe42884f2a2a7ca881b470be48.zip
dev-ruby/sinatra: fix tests with rack 3 present
Closes: https://bugs.gentoo.org/892700 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/sinatra/sinatra-2.2.3.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/dev-ruby/sinatra/sinatra-2.2.3.ebuild b/dev-ruby/sinatra/sinatra-2.2.3.ebuild
index 8267c1ef9643..5b8e56bf3948 100644
--- a/dev-ruby/sinatra/sinatra-2.2.3.ebuild
+++ b/dev-ruby/sinatra/sinatra-2.2.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -30,5 +30,8 @@ ruby_add_bdepend "test? ( >=dev-ruby/rack-test-0.5.6 dev-ruby/erubis dev-ruby/bu
ruby_add_bdepend "doc? ( dev-ruby/yard )"
all_ruby_prepare() {
- sed -i -e '/active_support\/core_ext\/hash/igem "activesupport", "<7"' test/helper.rb || die
+ sed -i -e '/active_support\/core_ext\/hash/igem "activesupport", "<7"' -e '1igem "rack", "~> 2.2.0"' test/helper.rb || die
+
+ # Avoid spec broken by newer rack versions, already removed upstream.
+ sed -i -e 's/"bytes=IV-LXVI", //' test/static_test.rb || die
}