summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-02-21 07:50:50 +0100
committerHans de Graaff <graaff@gentoo.org>2017-02-21 08:28:35 +0100
commit3427d62083358031bc61763dc5bbfae3aeabf981 (patch)
treeecad27d2950937f6fb62cd0ceae76f214fbfb60c /dev-ruby
parentdev-ruby/mocha: add ruby23, ruby24 (diff)
downloadgentoo-3427d62083358031bc61763dc5bbfae3aeabf981.tar.gz
gentoo-3427d62083358031bc61763dc5bbfae3aeabf981.tar.bz2
gentoo-3427d62083358031bc61763dc5bbfae3aeabf981.zip
dev-ruby/ruby-odbc: add 0.9998
Package-Manager: portage-2.3.3
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/ruby-odbc/Manifest1
-rw-r--r--dev-ruby/ruby-odbc/ruby-odbc-0.99998.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-ruby/ruby-odbc/Manifest b/dev-ruby/ruby-odbc/Manifest
index 8def5105ef6a..6d3efe7e68c0 100644
--- a/dev-ruby/ruby-odbc/Manifest
+++ b/dev-ruby/ruby-odbc/Manifest
@@ -1 +1,2 @@
DIST ruby-odbc-0.99997.tar.gz 76708 SHA256 23dbb3ad5b8579f18105d175d0249dec81c9fcdcb8ca638f2f7cc543940984fa SHA512 15ea850efa9f65467ea829c93f7dc9ecbef9409876b19d0a309d085b20e711da2888b918f77fcd26e6a40096358eab836d6bc3000c534da88f4f3c2b60a8662a WHIRLPOOL a3df94c5eb6b2e6edda55895e4954e18315b5b4cbb3b6a104e35be4c9949f8a594b01450b9ed3ce30965ab940099806b66c349d3179c7ed98e2b5e139118dc74
+DIST ruby-odbc-0.99998.tar.gz 76810 SHA256 c6e61a32793239121dbcac84c4c11b5a5b4d8d70d7d54bfc640d053ee8f4a717 SHA512 c983ca10cd21255d2a927deaac9c4689251f1149cc3c5b0b2a5578d5abdf2eb030a0bd726761eeb07abfb470e611316239de899d4739f4a380a598f4e0881f57 WHIRLPOOL 9c1346be698d073de7e6492c852fc6c495cd5ca768b8537128c38059d1c3401b1d4640466cd2513097bb4474227c8ce315484ebee9ccd781370d9d012ff7b59e
diff --git a/dev-ruby/ruby-odbc/ruby-odbc-0.99998.ebuild b/dev-ruby/ruby-odbc/ruby-odbc-0.99998.ebuild
new file mode 100644
index 000000000000..bdfce7328a57
--- /dev/null
+++ b/dev-ruby/ruby-odbc/ruby-odbc-0.99998.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README ChangeLog"
+
+inherit ruby-fakegem
+
+DESCRIPTION="RubyODBC - For accessing ODBC data sources from the Ruby language"
+HOMEPAGE="http://www.ch-werner.de/rubyodbc/"
+SRC_URI="http://www.ch-werner.de/rubyodbc/${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 Ruby )"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="${DEPEND} >=dev-db/unixODBC-2.0.6"
+RDEPEND="${RDEPEND} >=dev-db/unixODBC-2.0.6"
+
+# tests require to have an ODBC service enabled, so we can't run them
+# for now :(
+RESTRICT=test
+
+all_ruby_prepare() {
+ # Make sure that it doesn't try to use the absolute-local path for
+ # the extension as we'd be unable to run it properly otherwise.
+ sed -i -e 's:\./odbc:odbc:' test/{,utf8/}test.rb || die
+
+ # Since lib should not get installed avoid it entirely…
+ mv lib contrib || die
+}
+
+each_ruby_configure() {
+ for dir in ext ext/utf8; do
+ ${RUBY} -C${dir} extconf.rb --disable-dlopen || die "extconf (${dir}) failed"
+ done
+}
+
+each_ruby_compile() {
+ for dir in ext ext/utf8; do
+ emake V=1 -C${dir} || die "emake (${dir}) failed"
+ done
+}
+
+each_ruby_install() {
+ each_fakegem_install
+
+ ruby_fakegem_newins ext/odbc.so lib/odbc.so
+ ruby_fakegem_newins ext/utf8/odbc_utf8.so lib/odbc_utf8.so
+}
+
+all_ruby_install() {
+ all_fakegem_install
+ dohtml doc/*.html || die
+}