summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-06-09 08:33:48 +0200
committerHans de Graaff <graaff@gentoo.org>2020-06-09 08:39:21 +0200
commit387eddc2bbaf7d0842812933ebafec2963b4bc3e (patch)
tree07e2096b9bc29074beab24015c0dce2461619a2a /dev-ruby
parentapp-editors/kakoune: keyword ~ppc64, #726356 (diff)
downloadgentoo-387eddc2bbaf7d0842812933ebafec2963b4bc3e.tar.gz
gentoo-387eddc2bbaf7d0842812933ebafec2963b4bc3e.tar.bz2
gentoo-387eddc2bbaf7d0842812933ebafec2963b4bc3e.zip
dev-ruby/bunny: fix amq-protocol dependency
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/bunny/bunny-2.15.0-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ruby/bunny/bunny-2.15.0-r1.ebuild b/dev-ruby/bunny/bunny-2.15.0-r1.ebuild
new file mode 100644
index 000000000000..23b946645963
--- /dev/null
+++ b/dev-ruby/bunny/bunny-2.15.0-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby24 ruby25 ruby26 ruby27"
+
+# Tests require a live AMQP server.
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_EXTRADOC="ChangeLog.md README.md"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Another synchronous Ruby AMQP client"
+HOMEPAGE="https://github.com/celldee/bunny"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/amq-protocol-2.3.1:2"
+
+all_ruby_install() {
+ all_fakegem_install
+
+ dodoc -r examples
+}