summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Bracht Laumann Jespersen <t@laumann.xyz>2022-06-08 21:38:10 +0200
committerSam James <sam@gentoo.org>2022-06-16 17:30:28 +0100
commit391b6244d99d3e64a47821c7f14c84b94887e54b (patch)
tree4196cd354512d4c1d829ac6d5b4bc49451913160 /dev-ruby
parentdev-python/shiboken2: fix unquoted variable EPREFIX (diff)
downloadgentoo-391b6244d99d3e64a47821c7f14c84b94887e54b.tar.gz
gentoo-391b6244d99d3e64a47821c7f14c84b94887e54b.tar.bz2
gentoo-391b6244d99d3e64a47821c7f14c84b94887e54b.zip
dev-ruby/hiera-eyaml: fix unquoted variables
Signed-off-by: Thomas Bracht Laumann Jespersen <t@laumann.xyz> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/hiera-eyaml/hiera-eyaml-3.1.1.ebuild6
-rw-r--r--dev-ruby/hiera-eyaml/hiera-eyaml-3.2.2.ebuild6
2 files changed, 6 insertions, 6 deletions
diff --git a/dev-ruby/hiera-eyaml/hiera-eyaml-3.1.1.ebuild b/dev-ruby/hiera-eyaml/hiera-eyaml-3.1.1.ebuild
index 29e79172ccd4..cb1acb35e03f 100644
--- a/dev-ruby/hiera-eyaml/hiera-eyaml-3.1.1.ebuild
+++ b/dev-ruby/hiera-eyaml/hiera-eyaml-3.1.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -31,7 +31,7 @@ all_ruby_prepare() {
sed -i -e '/highline/ s/~>/>=/' \
-e '/gem.files/d' ${RUBY_FAKEGEM_GEMSPEC} || die
- sed -i -e 's:/tmp:'${T}':' \
+ sed -i -e "s:/tmp:${T}:" \
features/sandbox/puppet/environments/local/modules/test/manifests/run.pp \
features/sandbox/puppet-hiera-merge/environments/local/modules/test/manifests/run.pp \
features/puppet.feature
@@ -39,7 +39,7 @@ all_ruby_prepare() {
each_ruby_prepare() {
# Run tests with the correct ruby interpreter
- sed -i -e 's:I run `eyaml:I run `'${RUBY}' '${S}'/bin/eyaml:' features/*.feature || die
+ sed -i -e 's:I run `eyaml:I run `'${RUBY}' '"${S}"'/bin/eyaml:' features/*.feature || die
}
diff --git a/dev-ruby/hiera-eyaml/hiera-eyaml-3.2.2.ebuild b/dev-ruby/hiera-eyaml/hiera-eyaml-3.2.2.ebuild
index 076d16797b4c..c20c61b8599b 100644
--- a/dev-ruby/hiera-eyaml/hiera-eyaml-3.2.2.ebuild
+++ b/dev-ruby/hiera-eyaml/hiera-eyaml-3.2.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -31,7 +31,7 @@ all_ruby_prepare() {
sed -i -e '/highline/ s/~>/>=/' \
-e '/gem.files/d' ${RUBY_FAKEGEM_GEMSPEC} || die
- sed -i -e 's:/tmp:'${T}':' \
+ sed -i -e "s:/tmp:${T}:" \
features/sandbox/puppet/environments/local/modules/test/manifests/run.pp \
features/sandbox/puppet-hiera-merge/environments/local/modules/test/manifests/run.pp \
features/sandbox/puppet-envvar/environments/local/modules/test/manifests/run.pp \
@@ -40,7 +40,7 @@ all_ruby_prepare() {
each_ruby_prepare() {
# Run tests with the correct ruby interpreter
- sed -i -e 's:I run `eyaml:I run `'${RUBY}' '${S}'/bin/eyaml:' features/*.feature || die
+ sed -i -e 's:I run `eyaml:I run `'${RUBY}' '"${S}"'/bin/eyaml:' features/*.feature || die
}