summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-01-28 07:54:34 +0100
committerHans de Graaff <graaff@gentoo.org>2022-01-28 08:06:45 +0100
commit39c91af6ee89206bd036a74e751d121e1c21f6b2 (patch)
treeb91135d2c1b335b0f6faaf8a99c89a8099b6c178 /dev-ruby
parentdev-ml/camlidl: 1.09 bump (diff)
downloadgentoo-39c91af6ee89206bd036a74e751d121e1c21f6b2.tar.gz
gentoo-39c91af6ee89206bd036a74e751d121e1c21f6b2.tar.bz2
gentoo-39c91af6ee89206bd036a74e751d121e1c21f6b2.zip
dev-ruby/rspec-core: add 3.10.2
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/rspec-core/Manifest1
-rw-r--r--dev-ruby/rspec-core/rspec-core-3.10.2.ebuild91
2 files changed, 92 insertions, 0 deletions
diff --git a/dev-ruby/rspec-core/Manifest b/dev-ruby/rspec-core/Manifest
index 517b5c4392b2..636341d41e6e 100644
--- a/dev-ruby/rspec-core/Manifest
+++ b/dev-ruby/rspec-core/Manifest
@@ -1,3 +1,4 @@
DIST rspec-core-2.99.2-git.tgz 212935 BLAKE2B 37195012f79aca3a1959f9143e2f5cbab63230ab07ea97928d6f66face8d07ab54d87f19535f5f235c441b2da6dec17ef2a889e9ccd7e83d987086e24afd1b82 SHA512 e13bc3384fd85c367481a8651c14be4a412cba5f58e12a8f4ab14b5d2768a7b92191b81e000e7dbf6a28275b41044d8b3eb70a04e4b30b5bf88db98cbec4cc44
DIST rspec-core-3.10.1-git.tgz 398302 BLAKE2B 3ecd2a93b77435ef44dd7e52e2987155f71de3b04376dfbfc9c831ce075b4105f6a23a210f8508784b66c46f1126c188a3bd0548cc4f24060373b9c7e0b79101 SHA512 2d134e742e36cfaac0a52fa7ebd949391cfe58419956536a65fa3aefa2c7f3638fe19f7324ca3e0d2642cc5a9d33de11b09bd571844f1cfae9c077e5f27563d5
+DIST rspec-core-3.10.2-git.tgz 400299 BLAKE2B 82fe8689022f69f444549d654cd4799f8f1dff7c984016eba0835cffb518dce892a0af61a3ef6b251c598aa3caac66b0498620dc8d2b06a02795fc6ff3f46c41 SHA512 0ebeea8aed275f08bcac4846977b0718f85d95dedaed82b99280e5b52519713be6234d97b34b61a56e3276e767f47a13e6888401bd5a4b8a0003c9bbb518364d
DIST rspec-core-3.9.3-git.tgz 396080 BLAKE2B ea52a33586dc32af49a72950c7dbf24eef52a74891b2d7004ec4c5083e2e6d63c602f5033fba3a8ec1dfe6e8da349208b468a79b4e16aa5150d2fc8e93055c0e SHA512 f821ae3017c0fd9ac7f3ced0e81d0ebc54f2c17261f426c58a46c0bf1debb20efca7acc4b751b671e160de72ce5790f897bcb55d5d276fab228a4ea8d388a046
diff --git a/dev-ruby/rspec-core/rspec-core-3.10.2.ebuild b/dev-ruby/rspec-core/rspec-core-3.10.2.ebuild
new file mode 100644
index 000000000000..4fcf7ab73a72
--- /dev/null
+++ b/dev-ruby/rspec-core/rspec-core-3.10.2.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_TASK_TEST="none"
+
+RUBY_FAKEGEM_EXTRADOC="Changelog.md README.md"
+
+# Also install this custom path since internal paths depend on it.
+RUBY_FAKEGEM_EXTRAINSTALL="exe"
+
+RUBY_FAKEGEM_GEMSPEC="rspec-core.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
+HOMEPAGE="https://github.com/rspec/rspec-core"
+SRC_URI="https://github.com/rspec/${PN}/archive/v${PV}.tar.gz -> ${P}-git.tgz"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="highlight"
+
+SUBVERSION="$(ver_cut 1-2)"
+
+ruby_add_rdepend "
+ =dev-ruby/rspec-support-${SUBVERSION}*
+ highlight? ( >=dev-ruby/coderay-1.1.1 )
+"
+
+ruby_add_bdepend "test? (
+ >=dev-ruby/nokogiri-1.5.2
+ >=dev-ruby/coderay-1.1.1
+ dev-ruby/syntax
+ >=dev-ruby/thread_order-1.1.0
+ >=dev-ruby/rspec-expectations-3.8.0:3
+ >=dev-ruby/rspec-mocks-2.99.0:3
+ >=dev-ruby/rspec-support-3.9.1:3
+ )"
+
+all_ruby_prepare() {
+ # Don't set up bundler: it doesn't understand our setup.
+ sed -i -e '/[Bb]undler/d' Rakefile || die
+
+ # Avoid dependency on cucumber since we can't run the features anyway.
+ sed -i -e '/[Cc]ucumber/ s:^:#:' Rakefile || die
+
+ # Duplicate exe also in bin. We can't change it since internal stuff
+ # also depends on this and fixing that is going to be fragile. This
+ # way we can at least install proper bin scripts.
+ cp -R exe bin || die
+
+ # Avoid unneeded dependency on git.
+ sed -i -e 's/git ls-files --/find/' rspec-core.gemspec || die
+
+ # Avoid aruba dependency so that we don't end up in dependency hell.
+ sed -i -e '/ArubaLoader/,/^end/ s:^:#:' -e '/Aruba/ s:^:#:' spec/spec_helper.rb || die
+ rm -f spec/support/aruba_support.rb || die
+ rm -f spec/integration/{bisect_runners,failed_line_detection,filtering,order,persistence_failures,suite_hooks_errors}_spec.rb || die
+ rm -f spec/integration/{spec_file_load_errors,output_stream,fail_if_no_examples}_spec.rb || die
+
+ # Avoid a spec failing due to path issues
+ sed -i -e '/does not load files in the default path when run by ruby/,/end/ s:^:#:' \
+ spec/rspec/core/configuration_spec.rb || die
+
+ # Avoid a spec that depends on dev-ruby/rspec to lessen circular
+ # dependencies, bug 662328
+ sed -i -e '/loads mocks and expectations when the constants are referenced/askip "gentoo: bug 662328"' spec/rspec/core_spec.rb || die
+
+ # Avoid a spec depending on specifics on local networks
+ # This fails when localhost resolves to ::1 which may be a
+ # ruby regression in the drb/acl code.
+ rm -f spec/rspec/core/bisect/server_spec.rb || die
+}
+
+each_ruby_prepare() {
+ sed -i -e 's:ruby -e:'${RUBY}' -e:' spec/rspec/core_spec.rb || die
+}
+
+each_ruby_test() {
+ PATH="${S}/bin:${PATH}" RUBYLIB="${S}/lib" ${RUBY} -Ilib bin/rspec spec || die "Tests failed."
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ ruby_fakegem_binwrapper rspec /usr/bin/rspec-3 'gem "rspec", "~>3.0"'
+}