summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-07-13 12:11:09 +0200
committerHans de Graaff <graaff@gentoo.org>2021-07-13 12:17:16 +0200
commit43bd1a6e1d6532374beff6e334c7ab8736512c7e (patch)
treecbf83ec8e4faf3e803e8cc98432edd0a409ea4d4 /dev-ruby
parentdev-util/cucumber-html-formatter: import of 13.0.0 (diff)
downloadgentoo-43bd1a6e1d6532374beff6e334c7ab8736512c7e.tar.gz
gentoo-43bd1a6e1d6532374beff6e334c7ab8736512c7e.tar.bz2
gentoo-43bd1a6e1d6532374beff6e334c7ab8736512c7e.zip
dev-ruby/diva: fix addressable dependency
Allow addressable 2.8 since previous version have security issues. All tests pass with addressable 2.8. Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/diva/Manifest1
-rw-r--r--dev-ruby/diva/diva-1.0.2-r2.ebuild (renamed from dev-ruby/diva/diva-1.0.2-r1.ebuild)8
-rw-r--r--dev-ruby/diva/diva-1.0.2.ebuild28
3 files changed, 4 insertions, 33 deletions
diff --git a/dev-ruby/diva/Manifest b/dev-ruby/diva/Manifest
index f8b31f115820..d2f3136f7799 100644
--- a/dev-ruby/diva/Manifest
+++ b/dev-ruby/diva/Manifest
@@ -1,2 +1 @@
-DIST diva-1.0.2.gem 13824 BLAKE2B c292e11d9975691d85cb0500ec42b10422665abb9b236d44629d0a9518e318cf91891d4ad265aab81d13762d121910a8be92c602225d44bfa66e31e77082fa95 SHA512 b5d2df59e4144930ee18c7b738e8b93646057935364c2710d349761e68053f1c342b382de76dc1669076db7394ff906384a8952e1e7c44c71f208dc3604d67f4
DIST diva-1.0.2.tar.gz 13638 BLAKE2B 461e8487e06749d0482b86fd30945dc83d53daea06750628839c899b6f8d419599c9cc322b62f58d3eb956a2a99a3674dd591c4bb2fc5483bd1853bc40154634 SHA512 b60d80ca55c98a2f6fcf269aa4a2188f2239b871b0e77f328490d5924a6d0e6801c67d0eef4de28b584303f38bed3752a3ceb2c1e4f2c7d17be13dad03c643b5
diff --git a/dev-ruby/diva/diva-1.0.2-r1.ebuild b/dev-ruby/diva/diva-1.0.2-r2.ebuild
index cd07c32b70cd..70749dfdb14b 100644
--- a/dev-ruby/diva/diva-1.0.2-r1.ebuild
+++ b/dev-ruby/diva/diva-1.0.2-r2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-USE_RUBY="ruby24 ruby25 ruby26 ruby27"
+USE_RUBY="ruby26 ruby27"
RUBY_FAKEGEM_EXTRADOC="README.md"
@@ -22,9 +22,9 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-ruby_add_rdepend "<dev-ruby/addressable-2.8"
+ruby_add_rdepend "<dev-ruby/addressable-2.9"
all_ruby_prepare() {
sed -i -e '/bundler/ s:^:#:' Rakefile || die
- sed -i -e 's/git ls-files -z/find -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+ sed -i -e '/addressable/ s/2.8/2.9/' -e 's/git ls-files -z/find -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
}
diff --git a/dev-ruby/diva/diva-1.0.2.ebuild b/dev-ruby/diva/diva-1.0.2.ebuild
deleted file mode 100644
index f026d01e2f5a..000000000000
--- a/dev-ruby/diva/diva-1.0.2.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-USE_RUBY="ruby24 ruby25 ruby26 ruby27"
-
-RUBY_FAKEGEM_EXTRADOC="README.md"
-
-RUBY_FAKEGEM_BINWRAP=""
-
-RUBY_FAKEGEM_GEMSPEC="diva.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Implementation of expression for handling things."
-HOMEPAGE="https://github.com/toshia/diva https://rubygems.org/gems/diva"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-ruby_add_rdepend "<dev-ruby/addressable-2.8"
-
-all_ruby_prepare() {
- sed -i -e 's/git ls-files -z/find -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
-}