summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-12-22 06:56:30 +0100
committerHans de Graaff <graaff@gentoo.org>2017-12-22 06:56:30 +0100
commit4bf68d57854c9c36beb91ad92f7eca040b0b61e7 (patch)
treec23da20917aa7d84c1e9083f4bf1208b042dbab2 /dev-ruby
parentdev-ruby/json: cleanup (diff)
downloadgentoo-4bf68d57854c9c36beb91ad92f7eca040b0b61e7.tar.gz
gentoo-4bf68d57854c9c36beb91ad92f7eca040b0b61e7.tar.bz2
gentoo-4bf68d57854c9c36beb91ad92f7eca040b0b61e7.zip
dev-ruby/multi_json: cleanup
Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/multi_json/Manifest1
-rw-r--r--dev-ruby/multi_json/multi_json-1.9.3.ebuild61
2 files changed, 0 insertions, 62 deletions
diff --git a/dev-ruby/multi_json/Manifest b/dev-ruby/multi_json/Manifest
index 6dd34d176e6e..05418de8830c 100644
--- a/dev-ruby/multi_json/Manifest
+++ b/dev-ruby/multi_json/Manifest
@@ -1,3 +1,2 @@
DIST multi_json-1.12.1.tar.gz 25579 BLAKE2B 50fa37b907289b8247ffff1e22ebde1b07ee32e5ca97984be1243340f14185ebaaeb72cb28a18c5c77b1b48bfd0b400479fe7ef532e40cef3736d782c84c0d09 SHA512 f61e500197c5a1373443b308bd9307238c54d2d23ba9da91843c667c12e491f34fd87575028c3630a81a7355d4903344996f20408bbb7971b12dfba3cc4f76df
DIST multi_json-1.12.2.tar.gz 25630 BLAKE2B 61209dc4be50b44302cfe40e45b840ae8d81e827d8b9df82ca6b852a72d360fbe09c0f5b0ef8eecfbd08b6bd08343ab7bb307d91d9abf28c9b9adb35f18bea51 SHA512 bbbdd05a6dd12052aa3e09389f47212f15799310d5c265057f7ca801622d32295d1f0844b37e51f8f1fd2d48e4430234f99bc6de4b9ed149e81d9a33a831e6d9
-DIST multi_json-1.9.3.gem 30720 BLAKE2B 9e5fd49a1fd79857bd7c907d536d7e6eee9908720bca8a33abf9f1ff18deb68965140cf978d0d10323edf7e2f426aaa5925dc692fb5707c6f879f4921651a799 SHA512 7f06747e760a63b6421dfda480522924f12bd00ad63f95414f6624173b9b9b255b139f9dc33d2d2a8d19b232f99a005033e00e3a0b223be992f73d142a55b8b5
diff --git a/dev-ruby/multi_json/multi_json-1.9.3.ebuild b/dev-ruby/multi_json/multi_json-1.9.3.ebuild
deleted file mode 100644
index 3772a8234e19..000000000000
--- a/dev-ruby/multi_json/multi_json-1.9.3.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-USE_RUBY="ruby20 ruby21 ruby22"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec"
-RUBY_FAKEGEM_TASK_DOC="yard"
-
-RUBY_FAKEGEM_DOCDIR="rdoc"
-RUBY_FAKEGEM_EXTRADOC="README.md"
-
-RUBY_FAKEGEM_GEMSPEC="multi_json.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A gem to provide swappable JSON backends"
-HOMEPAGE="https://github.com/intridea/multi_json"
-LICENSE="MIT"
-
-KEYWORDS="alpha amd64 arm ~hppa ia64 ppc ppc64 ~sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-SLOT="0"
-IUSE=""
-
-ruby_add_rdepend "|| ( >=dev-ruby/json-1.4 >=dev-ruby/yajl-ruby-0.7 )"
-
-ruby_add_bdepend "doc? ( dev-ruby/rspec:2 dev-ruby/yard )"
-
-ruby_add_bdepend "test? ( dev-ruby/json
- dev-ruby/yajl-ruby )"
-
-all_ruby_prepare() {
- sed -i -e '/[Bb]undler/d' Rakefile spec/spec_helper.rb || die "Unable to remove bundler."
- rm Gemfile || die "Unable to remove bundler Gemfile."
-
- # Remove unimportant rspec options not supported by rspec 2.6.
- rm .rspec || die
-
- # Remove specs specific to oj since we don't package oj yet.
- sed -i -e '/defaults to the best available gem/,/^ end/ s:^:#:' \
- -e '/Oj does not create symbols on parse/,/^ end/ s:^:#:' \
- -e '/with Oj.default_settings/,/^ end/ s:^:#:' \
- -e '/using one-shot parser/,/^ end/ s:^:#:' \
- spec/multi_json_spec.rb
-
- # Avoid simplecov which only works with ruby 1.9
- sed -i -e '/simplecov/d' -e '/SimpleCov.formatter/,/SimpleCov.start/ d' spec/spec_helper.rb || die
-
- # Remove unpackaged and for our purposes unneeded coveralls
- sed -i -e '/coveralls/d' spec/spec_helper.rb || die
-
- # Avoid testing unpackaged adapters
- rm spec/{gson,jr_jackson,oj}_adapter_spec.rb || die
-}
-
-each_ruby_test() {
- for t in spec/*_spec.rb; do
- ${RUBY} -S rspec ${t} || die
- done
-}