summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-08-18 06:59:26 +0200
committerHans de Graaff <graaff@gentoo.org>2018-08-18 07:03:06 +0200
commit4d7a1929bfe7dd36a4ed1ca603f8537948d25708 (patch)
tree15914c0732f09963a30bd542b15af5cb0aad27f3 /dev-ruby
parentdev-ruby/autoprefixer-rails: cleanup (diff)
downloadgentoo-4d7a1929bfe7dd36a4ed1ca603f8537948d25708.tar.gz
gentoo-4d7a1929bfe7dd36a4ed1ca603f8537948d25708.tar.bz2
gentoo-4d7a1929bfe7dd36a4ed1ca603f8537948d25708.zip
dev-ruby/ruby-progressbar: add 1.10.0
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/ruby-progressbar/Manifest1
-rw-r--r--dev-ruby/ruby-progressbar/ruby-progressbar-1.10.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-ruby/ruby-progressbar/Manifest b/dev-ruby/ruby-progressbar/Manifest
index 574141e11e16..180501ebe0de 100644
--- a/dev-ruby/ruby-progressbar/Manifest
+++ b/dev-ruby/ruby-progressbar/Manifest
@@ -1,2 +1,3 @@
+DIST ruby-progressbar-1.10.0.tar.gz 51483 BLAKE2B 24b92718fe933caa29460939a816b14a492d3144e9a891839ec3b5dbac103849bc0aa3becfb47e507a001ce6b0d0bbf2e0b207fe8d7cb51443924e81c9395b0a SHA512 ec645858d619a95081304905661918eef6d5bd19c0f8d00beac48df3f202d18ac85811d51028d71ab144a5a56649feb2409eca59b3db26733c00a1a54a7ef55d
DIST ruby-progressbar-1.4.2.gem 24064 BLAKE2B 4c26f5c281129a7333c8a7a1f7738a094ec02d769293252c8fbc6df0bea99971cd0d235b6bbeba7e2e4fac10409028f7cdb15870484878c26d9ea9f709f0135b SHA512 443fc015b2dcabc76c685f1529a39ffba289cb00c3cee3992ef240fb9822729f9049db4d85c58ee1ab6cc17927cb325044ea45a968c755a9b5ad93f7b9999fbd
DIST ruby-progressbar-1.9.0.tar.gz 47888 BLAKE2B 26707f4f931e378da18a29d20da47963c06bde537155d0e9bd3a623b9b3edd9d653a50ca106dcb29ffb53668a869815818398ae514ef3302465cf5a5504b2cda SHA512 d2b01c205dec3bad6989a1ea466070fdc0c3fc5bc0c8685a21094c52d2f2c6a11849b42d88d3ec70df1475ad47c9f84a4c4b603948344643310e2180122d9b67
diff --git a/dev-ruby/ruby-progressbar/ruby-progressbar-1.10.0.ebuild b/dev-ruby/ruby-progressbar/ruby-progressbar-1.10.0.ebuild
new file mode 100644
index 000000000000..033082b7ba8b
--- /dev/null
+++ b/dev-ruby/ruby-progressbar/ruby-progressbar-1.10.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Text Progress Bar Library for Ruby"
+HOMEPAGE="https://github.com/jfelchner/ruby-progressbar"
+SRC_URI="https://github.com/jfelchner/ruby-progressbar/archive/releases/v${PV}.tar.gz -> ${P}.tar.gz"
+RUBY_S="ruby-progressbar-releases-v${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+IUSE="test"
+
+ruby_add_bdepend "test? ( dev-ruby/rspectacular dev-ruby/timecop )"
+
+all_ruby_prepare() {
+ sed -i -e '/warning_filter/ s:^:#:' \
+ spec/spec_helper.rb || die
+ # Avoid ruby24 syntax for an unneeded check
+ sed -i -e '/^return/ s:^:#:' spec/ruby-progressbar/refinements/enumerator_spec.rb || die
+}