summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-02-17 08:34:31 +0100
committerHans de Graaff <graaff@gentoo.org>2018-02-17 08:34:31 +0100
commit4f4564eb181a767bda25ceaf541163e167e6dd00 (patch)
tree677a599c964cd54533d152d0cb250fd726190eab /dev-ruby
parentdev-ruby/parser: add 2.5.0.0 (diff)
downloadgentoo-4f4564eb181a767bda25ceaf541163e167e6dd00.tar.gz
gentoo-4f4564eb181a767bda25ceaf541163e167e6dd00.tar.bz2
gentoo-4f4564eb181a767bda25ceaf541163e167e6dd00.zip
dev-ruby/sigar: fix build with glibc 2.26
Thanks to Reuben Martin in bug 639470. Closes: https://bugs.gentoo.org/639470 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/sigar/sigar-0.7.3.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/dev-ruby/sigar/sigar-0.7.3.ebuild b/dev-ruby/sigar/sigar-0.7.3.ebuild
index 03c1758bc3ef..116f75eba323 100644
--- a/dev-ruby/sigar/sigar-0.7.3.ebuild
+++ b/dev-ruby/sigar/sigar-0.7.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -18,8 +18,11 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
+DEPEND+=" || ( <sys-libs/glibc-2.26 net-libs/libtirpc )"
+
all_ruby_prepare() {
- sed -i -e '25i$CFLAGS += " -std=gnu89"' bindings/ruby/extconf.rb || die
+ sed -i -e '25i$CFLAGS += " -std=gnu89"' \
+ -e '25i$LDFLAGS += " -ltirpc"' bindings/ruby/extconf.rb || die
# Fix compatibility with glibc 2.25
sed -i -e '26i#include <sys/sysmacros.h>' \