summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-03-30 08:44:46 +0200
committerHans de Graaff <graaff@gentoo.org>2022-03-31 07:39:22 +0200
commit5ba5c34cee44cd5726195ffbfa76e35fba62bca4 (patch)
treefc52a50db8afc9ed1520bfb48277049a2f6a3921 /dev-ruby
parentdev-ruby/thread_order: enable ruby31 and disable ruby25 (diff)
downloadgentoo-5ba5c34cee44cd5726195ffbfa76e35fba62bca4.tar.gz
gentoo-5ba5c34cee44cd5726195ffbfa76e35fba62bca4.tar.bz2
gentoo-5ba5c34cee44cd5726195ffbfa76e35fba62bca4.zip
dev-ruby/rspec-support: enable ruby31
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/rspec-support/rspec-support-3.11.0.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/dev-ruby/rspec-support/rspec-support-3.11.0.ebuild b/dev-ruby/rspec-support/rspec-support-3.11.0.ebuild
index d7fe9d10c9e9..b655ae6d9d07 100644
--- a/dev-ruby/rspec-support/rspec-support-3.11.0.ebuild
+++ b/dev-ruby/rspec-support/rspec-support-3.11.0.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-USE_RUBY="ruby26 ruby27 ruby30"
+USE_RUBY="ruby26 ruby27 ruby30 ruby31"
RUBY_FAKEGEM_RECIPE_TEST="rspec3"
@@ -44,6 +44,15 @@ all_ruby_prepare() {
each_ruby_prepare() {
# Use the ruby version being tested
sed -i -e '/shell_out/ s:ruby:'${RUBY}':' spec/rspec/support/spec/shell_out_spec.rb || die
+
+ case ${RUBY} in
+ *ruby31)
+ # Avoid specs failing when run in Gentoo, possibly due to different IO
+ sed -e '/outputs unified diff message of two arrays/askip "ruby31 IO"' \
+ -e '/outputs unified diff message for hashes inside arrays with differing key orders/askip "ruby31 IO"' \
+ -i spec/rspec/support/differ_spec.rb || die
+ ;;
+ esac
}
each_ruby_test() {