summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-06-04 05:50:09 +0200
committerHans de Graaff <graaff@gentoo.org>2016-06-04 05:50:53 +0200
commit6709912be8a525d9a8dc6d7b0f71af506084ddaa (patch)
tree3d5d88b9ef9414a6825499f7465840f50171985c /dev-ruby
parentdev-ruby/semantic_puppet: add 0.1.3 (diff)
downloadgentoo-6709912be8a525d9a8dc6d7b0f71af506084ddaa.tar.gz
gentoo-6709912be8a525d9a8dc6d7b0f71af506084ddaa.tar.bz2
gentoo-6709912be8a525d9a8dc6d7b0f71af506084ddaa.zip
dev-ruby/tilt: add 2.0.5
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/tilt/Manifest1
-rw-r--r--dev-ruby/tilt/tilt-2.0.5.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-ruby/tilt/Manifest b/dev-ruby/tilt/Manifest
index 3ed7649fbf89..4de184b352aa 100644
--- a/dev-ruby/tilt/Manifest
+++ b/dev-ruby/tilt/Manifest
@@ -2,3 +2,4 @@ DIST tilt-1.4.1.gem 42496 SHA256 39820562c4f5db45fe18de87ccc30a0e77a998bf5334b1d
DIST tilt-2.0.2.gem 48640 SHA256 04c91dcf7533576196e3ea2ba22514f37811ab7419bab6c71877e2e63a206d52 SHA512 93540d673f1c0e841be43e54e85451482f6ea8f967d14bce46c997be69a9ff16684aa5966c91cfd8d590cc32ef590974151183839ec315d46df5d398fd016832 WHIRLPOOL 051c29727ce157bf73d1c276c500471a48bde23a8a0ce516ad75e88a99b738e7c1a0283070db2c127922582e4f674e8591c69d36821744d5d09a3d0f9d0bd03f
DIST tilt-2.0.3.gem 51712 SHA256 4e68572c96e77f0dfcdc121958060a0d60a17a4be3fc7aca4a65b0500bc80c6a SHA512 762682dce36ff0e6614558dd3a8e2c81474f3c94c8a6330c8c17a773527ec410ca032f3a75af9189f82c16e8d803f0f16d76155aeaf8d4844543f1abf5efe7db WHIRLPOOL fdbe322c67bfd0c1224de8cefedf8733e684581d55ce93cedf39372b0ea73f698146c60aed7f95d1e3ca57439262006b237c6ca853c72878de6ce966f422eb23
DIST tilt-2.0.4.gem 51712 SHA256 47bc2e43480f7d29291a0dcb1395dd6e2badd6ed61b4e78dd695d64061fddb1f SHA512 86a0953cc56cf256aa6fb30eb373f8ebea69c76a1161c617e28a8b7244b1b327fd8abb1a084771a3f3f32c5fc90249fa111b33f040bbf15a13e4854671453d1d WHIRLPOOL 8f693de9978447baa54bc85a4630de12c0d2581e70fe18eb28b7d09a52532faaea5294a83d6a91b0e0c0c7a22f4bacc9c97eaae299eaaab52003cbc992d01d48
+DIST tilt-2.0.5.gem 52224 SHA256 0ec3e46ff4dcbabe0e90af1e92786b3c88312ebca55816b04f2511d1dd42f351 SHA512 b032439d00e09d3968b20f5ea5937c5918b1e10e0255cce402b6859b7d59ecdc265523a151c0fcca0034e0de26ca5fe422944790939896d7e0000641980764fa WHIRLPOOL ab98e857c456b664e8364d037b800ace4559b3de317c72da116402d0845a697e1979c33a77606ebd976b7ac03d0ecd24d4c56711e53190ae62edb63bc19f8b9c
diff --git a/dev-ruby/tilt/tilt-2.0.5.ebuild b/dev-ruby/tilt/tilt-2.0.5.ebuild
new file mode 100644
index 000000000000..6b334ca9e0ff
--- /dev/null
+++ b/dev-ruby/tilt/tilt-2.0.5.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md docs/TEMPLATES.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Thin interface over template engines to make their usage as generic as possible"
+HOMEPAGE="https://github.com/rtomayko/tilt"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+# Block on some of the potential test dependencies. These dependencies
+# are optional for the test suite, and we don't want to depend on all of
+# them to faciliate keywording and stabling.
+ruby_add_bdepend "test? (
+ dev-ruby/bluecloth
+ dev-ruby/coffee-script
+ dev-ruby/erubis
+ dev-ruby/nokogiri
+ !!<dev-ruby/maruku-0.7.2 )"
+
+# Most dependencies are optional: skip haml and radius for ruby20 and ruby21
+# because haml depends on rails.
+USE_RUBY="ruby20 ruby21 ruby22" ruby_add_bdepend "test? ( dev-ruby/haml )"
+USE_RUBY="ruby20 ruby21" ruby_add_bdepend "test? ( dev-ruby/radius )"
+
+ruby_add_rdepend ">=dev-ruby/builder-2.0.0:*
+ !!<dev-ruby/tilt-1.4.1-r2:0"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+ sed -e '/bundler/I s:^:#:' -i Rakefile test/test_helper.rb || die
+
+ # Avoid tests with minor syntax differences since this happens all
+ # the time when details in the dependencies change.
+ sed -e '/test_smarty_pants_true/,/^ end/ s:^:#:' -i test/tilt_markdown_test.rb || die
+ sed -e '/smartypants when :smart is set/,/^ end/ s:^:#:' -i test/tilt_rdiscounttemplate_test.rb || die
+ #sed -i -e '/docbook templates/,/^ end/ s:^:#:' test/tilt_asciidoctor_test.rb || die
+}