summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-02-26 07:01:05 +0100
committerHans de Graaff <graaff@gentoo.org>2018-02-26 07:01:05 +0100
commit6a3c7ee7f4b0877d77e5287fc4ef5a2c76d01bf7 (patch)
tree710a0ea18adab64ddfe326d02c08cdaae0f4e099 /dev-ruby
parentmedia-video/libva-utils: Fix libva minimum dependency (diff)
downloadgentoo-6a3c7ee7f4b0877d77e5287fc4ef5a2c76d01bf7.tar.gz
gentoo-6a3c7ee7f4b0877d77e5287fc4ef5a2c76d01bf7.tar.bz2
gentoo-6a3c7ee7f4b0877d77e5287fc4ef5a2c76d01bf7.zip
dev-ruby/atomic: add 1.1.100
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/atomic/Manifest1
-rw-r--r--dev-ruby/atomic/atomic-1.1.100.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/atomic/Manifest b/dev-ruby/atomic/Manifest
index 81d21ec64eca..b2488b863ba1 100644
--- a/dev-ruby/atomic/Manifest
+++ b/dev-ruby/atomic/Manifest
@@ -1 +1,2 @@
+DIST atomic-1.1.100.gem 17920 BLAKE2B 47c96c49a572a6d6705b952e419e1a07f3b06de4e0235a4d9d98e6ff546c96aa9af69c39864107c6bec1ba7b92ca2a9ceef2cb5d5938c1c82f40973376920d6e SHA512 64c374b69b7ea8b7fc6aa3e189cb6ae3d4a9a214d410a83fa0ef464a55624792055c5e3e61adda3eff039aba604a0c1b710ba5304d33f27ae9cc6e421e8e1892
DIST atomic-1.1.99.gem 17920 BLAKE2B 814406dc3e38a3ec882eb47e20e6153da9f68c4dd6ba3bc3d3869c0542754ba38678512872b25379b12d902ad6f740b1da974680867d492d2c4620091c5a32c9 SHA512 9c7762f6c32d11b2c5b45be68954ca12c753d2b4683167158a037ce791d72b13d940beef5bf6dd445c8b12e358c62d2a9f43a609fb3b7c7357fea4f66316063c
diff --git a/dev-ruby/atomic/atomic-1.1.100.ebuild b/dev-ruby/atomic/atomic-1.1.100.ebuild
new file mode 100644
index 000000000000..811158c883e2
--- /dev/null
+++ b/dev-ruby/atomic/atomic-1.1.100.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+USE_RUBY="ruby22 ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="An atomic reference implementation for JRuby, Rubinius, and MRI"
+HOMEPAGE="https://github.com/headius/ruby-atomic"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE=""
+
+all_ruby_prepare() {
+ # Avoid compilation dependencies since we compile directly.
+ sed -i -e '/:test => :compile/ s:^:#:' \
+ -e '/extensiontask/,/end/ s:^:#:' Rakefile || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext
+ cp ext/atomic_reference$(get_modname) lib/ || die
+}