summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-07-06 06:40:36 +0200
committerHans de Graaff <graaff@gentoo.org>2018-07-06 08:49:28 +0200
commit6a901b89076b3f86dd9cebd8134267d02fc70cb3 (patch)
tree21b56b7ffc1a5288e0aed3f1d6e13e072ed0a359 /dev-ruby
parentapp-text/libnumbertext: Drop old (diff)
downloadgentoo-6a901b89076b3f86dd9cebd8134267d02fc70cb3.tar.gz
gentoo-6a901b89076b3f86dd9cebd8134267d02fc70cb3.tar.bz2
gentoo-6a901b89076b3f86dd9cebd8134267d02fc70cb3.zip
dev-ruby/ruby-gio2: backport fix for failing test
Closes: https://bugs.gentoo.org/645876 Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/ruby-gio2/files/ruby-gio2-3.1.1-schema-path.patch28
-rw-r--r--dev-ruby/ruby-gio2/ruby-gio2-3.1.1.ebuild4
2 files changed, 31 insertions, 1 deletions
diff --git a/dev-ruby/ruby-gio2/files/ruby-gio2-3.1.1-schema-path.patch b/dev-ruby/ruby-gio2/files/ruby-gio2-3.1.1-schema-path.patch
new file mode 100644
index 000000000000..437a9b8513ce
--- /dev/null
+++ b/dev-ruby/ruby-gio2/files/ruby-gio2-3.1.1-schema-path.patch
@@ -0,0 +1,28 @@
+From f9bb159674c4eb25f99550fa8594fcbf97ed8cae Mon Sep 17 00:00:00 2001
+From: Kouhei Sutou <kou@clear-code.com>
+Date: Mon, 30 Jan 2017 23:09:31 +0900
+Subject: [PATCH] gio2 test: fix path
+
+GitHub: fix #990
+
+Reported by Mamoru TASAKA. Thanks!!!
+---
+ gio2/test/test-settings.rb | 5 ++++-
+ 1 file changed, 4 insertions(+), 1 deletion(-)
+
+diff --git a/gio2/test/test-settings.rb b/gio2/test/test-settings.rb
+index b16341c84..5a287f1e9 100644
+--- a/gio2/test/test-settings.rb
++++ b/gio2/test/test-settings.rb
+@@ -108,7 +108,10 @@ def need_keyfile_settings_backend
+ need_keyfile_settings_backend
+ keyfile = Tempfile.new(["settings", ".ini"])
+ backend = Gio::keyfile_settings_backend_new(keyfile.path, "/", "keyfile_settings")
+- schema_source = Gio::SettingsSchemaSource.new(fixture_path("schema"), nil, true)
++ schema_dir = fixture_path("schema", "default")
++ schema_source = Gio::SettingsSchemaSource.new(schema_dir,
++ nil,
++ true)
+ schema = schema_source.lookup("jp.ruby-gnome2.test.settings", true)
+ settings = Gio::Settings.new(schema,
+ backend,
diff --git a/dev-ruby/ruby-gio2/ruby-gio2-3.1.1.ebuild b/dev-ruby/ruby-gio2/ruby-gio2-3.1.1.ebuild
index c208c5799775..346b4158f8e7 100644
--- a/dev-ruby/ruby-gio2/ruby-gio2-3.1.1.ebuild
+++ b/dev-ruby/ruby-gio2/ruby-gio2-3.1.1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=5
-USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+USE_RUBY="ruby23 ruby24"
inherit ruby-ng-gnome2
@@ -14,6 +14,8 @@ ruby_add_rdepend ">=dev-ruby/ruby-glib2-${PV}
>=dev-ruby/ruby-gobject-introspection-${PV}"
all_ruby_prepare() {
+ epatch "${FILESDIR}/${P}-schema-path.patch"
+
# Avoid unneeded dependency on test-unit-notify.
sed -i -e '/notify/ s:^:#:' \
test/gio2-test-utils.rb || die