summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-11-25 13:46:23 +0100
committerHans de Graaff <graaff@gentoo.org>2021-11-25 14:03:16 +0100
commit6ac99cf9c0002626fdcec3ba5721e57bf3d41681 (patch)
tree0ef88f5957a2fc417af2e4f18694db2775cb8c64 /dev-ruby
parentdev-ruby/ffi-compiler: add ruby30 (diff)
downloadgentoo-6ac99cf9c0002626fdcec3ba5721e57bf3d41681.tar.gz
gentoo-6ac99cf9c0002626fdcec3ba5721e57bf3d41681.tar.bz2
gentoo-6ac99cf9c0002626fdcec3ba5721e57bf3d41681.zip
dev-ruby/http-parser: fix extension install
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/http-parser/http-parser-1.2.3-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/http-parser/http-parser-1.2.3-r1.ebuild b/dev-ruby/http-parser/http-parser-1.2.3-r1.ebuild
new file mode 100644
index 000000000000..896944c223f9
--- /dev/null
+++ b/dev-ruby/http-parser/http-parser-1.2.3-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A super fast http parser for ruby"
+HOMEPAGE="https://github.com/cotag/http-parser"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+DEPEND+=" >=net-libs/http-parser-2.8.1"
+RDEPEND+=" >=net-libs/http-parser-2.8.1"
+
+ruby_add_bdepend "dev-ruby/ffi-compiler"
+
+each_ruby_compile() {
+ ${RUBY} -C ext -S rake || die
+ mv ext/*/libhttp-parser-ext.so lib/http-parser/ || die
+}
+
+each_ruby_install() {
+ each_fakegem_install
+ ruby_fakegem_extensions_installed
+}