summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-12-24 07:57:12 +0100
committerHans de Graaff <graaff@gentoo.org>2018-12-24 07:57:12 +0100
commit740fa543d21b27d5f8c85391f51e6619329d955d (patch)
tree77cf87dd8d3cfe3f44d7027e537ffdacb3b0c06b /dev-ruby
parentdev-ruby/cmdparse: add 3.0.4 (diff)
downloadgentoo-740fa543d21b27d5f8c85391f51e6619329d955d.tar.gz
gentoo-740fa543d21b27d5f8c85391f51e6619329d955d.tar.bz2
gentoo-740fa543d21b27d5f8c85391f51e6619329d955d.zip
dev-ruby/rack-protection: add 2.0.5
Signed-off-by: Hans de Graaff <graaff@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/rack-protection/Manifest1
-rw-r--r--dev-ruby/rack-protection/rack-protection-2.0.5.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-ruby/rack-protection/Manifest b/dev-ruby/rack-protection/Manifest
index ec4d7f0853a7..41cc46782bc3 100644
--- a/dev-ruby/rack-protection/Manifest
+++ b/dev-ruby/rack-protection/Manifest
@@ -2,3 +2,4 @@ DIST rack-protection-1.5.5.gem 18432 BLAKE2B abda1313e7e0d04299a689c55241cd92d0f
DIST rack-protection-2.0.2.gem 16896 BLAKE2B b3ed6a399f93c359a305cef0893bb5056ac26e8d5f345761f497b5eb77aecc201cd388bc0fc021ed039f230bc2ca2348f7eec19aaaac3f2662500bd4c6496a93 SHA512 e74be8b079a1c436d80df2e6bf58dcaea089aceb58b8ec6c08d6ac78b5390bdb1b494d9155350dc7e2639e858209aac10757be54085a565b910e5e74ee882235
DIST rack-protection-2.0.3.gem 16896 BLAKE2B e33cfc8290cf108f986bd625623411f63812aa79bc5354041e3d541a244bdc6f2ba30ebfab77cb2fe15c8a53e21e11adc6a54ab90a687147759d1b14b5e0be73 SHA512 396d1b45783e0b6782b479b6ba77c2eb23c2a6a2b695a631b7a4b9ace661471325d4d321a40ba7c8090964e68b5dd8f9c92c4843464e6d6ff178aecf9996f338
DIST rack-protection-2.0.4.gem 16896 BLAKE2B d20bd67bfcbb8ba34689cdc909c1f89305bc6a08c44b9cdde8a7d1615c86400572a24a060a9100c699791cd910e5bbf17106b8c921e1e6a21f814457a93dc2c1 SHA512 e934873e7e8e45c1fa0450b568f33e28db29b9c4bacb0a747218ca929e73706518c09ce131f749e89dc7af894dcfbd6fcabdf12324edbfbcfa532eb227f977a4
+DIST rack-protection-2.0.5.gem 16896 BLAKE2B 144888ca499739017ffec494785ca5cba0d1cbfabdf08b11aad4fc88aaaa737408d1801412f05919830c65fd11b2f344f0f758a0334b109174805d5089352521 SHA512 9c4c80a8f70042bea81a67260e26aa25c0a33c73835e4e49cd44c83930f97d8c4d63004d3e39ed631f016e44d66fba238f9c509b0e44eddb2f484d174adea9b4
diff --git a/dev-ruby/rack-protection/rack-protection-2.0.5.ebuild b/dev-ruby/rack-protection/rack-protection-2.0.5.ebuild
new file mode 100644
index 000000000000..7128d3fd8e4a
--- /dev/null
+++ b/dev-ruby/rack-protection/rack-protection-2.0.5.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby23 ruby24 ruby25"
+
+# There are no specs in the gem and the source cannot be downloaded separately.
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem eapi7-ver
+
+DESCRIPTION="This gem protects against typical web attacks"
+HOMEPAGE="https://github.com/rkh/rack-protection"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/rack:*"
+
+# ruby_add_bdepend "test? ( dev-ruby/rack-test )"