summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-08-12 08:03:00 +0200
committerHans de Graaff <graaff@gentoo.org>2018-08-12 08:03:00 +0200
commit74871f0ffee3c9cd541759b72e87dc5a9b16f443 (patch)
treefbac0f895ce509dfd5d03992afcc0c2049dd4fda /dev-ruby
parentsys-apps/portage: version bump to 2.3.46 (diff)
downloadgentoo-74871f0ffee3c9cd541759b72e87dc5a9b16f443.tar.gz
gentoo-74871f0ffee3c9cd541759b72e87dc5a9b16f443.tar.bz2
gentoo-74871f0ffee3c9cd541759b72e87dc5a9b16f443.zip
dev-ruby/yard: add 0.9.16
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/yard/Manifest1
-rw-r--r--dev-ruby/yard/yard-0.9.16.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-ruby/yard/Manifest b/dev-ruby/yard/Manifest
index ae5ec7391286..d5a4d2751552 100644
--- a/dev-ruby/yard/Manifest
+++ b/dev-ruby/yard/Manifest
@@ -1,3 +1,4 @@
DIST yard-0.9.11-git.tgz 916355 BLAKE2B e9f27fe129cf93c51dbf83f4a7d5745d385252ba63c90f85223f2e9436c22a55aaba296f263072069d39e4beaca3e0830775a8be121c64cdc2a15afd3539a73f SHA512 375a4878e61888cf73aaa06e9300195ae48b9898d8cd639fa796a067e5fa0b89d6ef62d327a388ee83953e80177515f4d8c070042188e3a1e597f48b82b3a72e
DIST yard-0.9.14-git.tgz 917830 BLAKE2B dd0d1d6dbc5aa9b549bd4c110f1abd57edc76b85e7c936bca8f7d35761d705ba86cd169c3c2b2141095dda68a8ab350b46bcbeb978d655addff78b110fbd2b71 SHA512 7974d431b2c1ef4830f225fd2012592405e7fb63546aeb52b74f4ad8b498926be979f3010bd315877bb4f738f6aa6c31f54b71832b461ebd3fa54fe1a1fccf5f
DIST yard-0.9.15-git.tgz 918280 BLAKE2B f7ae54298cfb8d19e006ad5e18525c3e73e423894e37c3af1fbf555227c4f66bbbcdae781addf7ad30ac900d2af7458550558fe75d876d9fa4c0cd5a2a1a3668 SHA512 45e3a6e170c06c0f7e7ff508d33e87ed9922be3e8fca19d272553b84e678fa209c44460665b86e508145b147dbbc6d4664b95694dbcf91c421988b233e63dd40
+DIST yard-0.9.16-git.tgz 918424 BLAKE2B 41213a87b108bbacf3d700ffbce67806619ff417b8c883b8f7c33bb1eda1e1d97176226a801d8fb8a888a4ed4e2bcb45c46a65b236bc39c9100bcc6200c5778d SHA512 0027fccf87ec86a8ad5d62ec02b10a9c50be82212a7ad0f9f79d41627a2b88cb886fdc832e0df5c28cf737ad9f308670bd98b4dbb8ddc21aeba76b5c6928ecf1
diff --git a/dev-ruby/yard/yard-0.9.16.ebuild b/dev-ruby/yard/yard-0.9.16.ebuild
new file mode 100644
index 000000000000..4270103786c4
--- /dev/null
+++ b/dev-ruby/yard/yard-0.9.16.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_TASK_DOC="yard"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_DOCDIR="doc docs"
+
+RUBY_FAKEGEM_EXTRAINSTALL="templates"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Documentation generation tool for the Ruby programming language"
+HOMEPAGE="https://yardoc.org/"
+
+# The gem lakes the gemspec file needed to pass tests.
+SRC_URI="https://github.com/lsegal/yard/archive/v${PV}.tar.gz -> ${P}-git.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "doc? ( || ( dev-ruby/maruku dev-ruby/rdiscount dev-ruby/bluecloth dev-ruby/kramdown ) )"
+
+ruby_add_bdepend "test? ( >=dev-ruby/ruby-gettext-2.3.8 dev-ruby/rack )"
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/ s:^:#:' spec/spec_helper.rb || die
+
+ # Avoid specs that make assumptions on load ordering that are not
+ # true for us. This may be related to how we install in Gentoo. This
+ # also drops a test requirement on dev-ruby/rack.
+ rm -f spec/cli/server_spec.rb || die
+
+ # Avoid specs that only work with bundler
+ sed -i -e '/#initialize/,/^ end/ s:^:#:' spec/cli/yri_spec.rb || die
+
+ # Avoid redcarpet-specific spec that is not optional
+ sed -i -e '/autolinks URLs/askip "make redcarpet optional"' spec/templates/helpers/html_helper_spec.rb || die
+}