summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-03-02 07:58:36 +0100
committerHans de Graaff <graaff@gentoo.org>2017-03-02 07:58:36 +0100
commit7c11864aed7e01ecb28ecfe1649f415fb66bfddc (patch)
tree9adb73347d3b02c8565bae9df3f8f94c7e27ead1 /dev-ruby
parentdev-ruby/ruby-progressbar: add missing timecop test dependency, fixing bug 59... (diff)
downloadgentoo-7c11864aed7e01ecb28ecfe1649f415fb66bfddc.tar.gz
gentoo-7c11864aed7e01ecb28ecfe1649f415fb66bfddc.tar.bz2
gentoo-7c11864aed7e01ecb28ecfe1649f415fb66bfddc.zip
dev-ruby/activesupport: add rails 5.0.2
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/activesupport/Manifest1
-rw-r--r--dev-ruby/activesupport/activesupport-5.0.2.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/dev-ruby/activesupport/Manifest b/dev-ruby/activesupport/Manifest
index c66c1cd6134e..35f2351e2d46 100644
--- a/dev-ruby/activesupport/Manifest
+++ b/dev-ruby/activesupport/Manifest
@@ -2,3 +2,4 @@ DIST rails-4.2.7.1.tgz 4181681 SHA256 bfa7854f1b35e449b78db2af83fe660f17b101a487
DIST rails-4.2.8.tgz 4077925 SHA256 55e15e101fc4a466a8acafdd679509f6e25992d50ade2d98b098558c698a6320 SHA512 a457ec7422b83f35e8d1ac26f1ef8fbaec985034c5804ce92334c45fa4e4b11a29acdcef2c009c36be2deb4724faeb91b99f76a665eeacd1bda9448db2299f89 WHIRLPOOL ed46c71f527ba59f0ff4d00ae5881b46984500b4493b4c511b8037d94c76b40c0e531c635337b0795887e028aad5136048ba69b57e482489c3c049585f18f42f
DIST rails-5.0.0.1.tgz 6139334 SHA256 3cbbe71d80c2813dde0d2bfa61aea57c8e6a1a3b2a81e6b211dbf2f2a4be2add SHA512 8e820f26543e8ad05b01a75e4e4df1adb229b5d90cfccd1b63d77a6ab25f232d24a875cd5630648e58c6598d741a3d35b2a76fd7e99a0f06971f84ee63ada56f WHIRLPOOL 9aed4fab1c8ea06185de5320ed85d6d51ed0babf6143c3d70df352adea5721c3074bb80c351b395752b2d8c60f5fcb8982b086e507836b9867d6597f2d72df4c
DIST rails-5.0.1.tgz 6026895 SHA256 7ee54f0175a7738e7c169fa8dc2e4ee30ba8407768804aaa56a6889525315f4e SHA512 d5c25b284b24399f81a5a8aec9c4b581d2caeff6d1f73b71dab2a50b8f55b4a86c1d723f0bae9b40bdb3d949e3d5eb65b7522bf9ca316676cafdd2cf648abb33 WHIRLPOOL 142190cc4f8edafdc39cdbab2586127815e145f4d4fa5a89f3c9b2377e70bc29f6d410359c0498fe1c83c8f811b64884ae0d7e06b20d8ffb5ec44c6b66cde49b
+DIST rails-5.0.2.tgz 6034813 SHA256 4ca4ab89c06776f959edde03833f83be05002db5a1028e9276d45db6a2358cd4 SHA512 bb82bd33e47b875f3a9bc6d833492b89fbf86afff27049f1f8710a406452dee1cb5b287b0e19d6b2f45ee59181b28425916746d1b6ef835029944aff4bcf255b WHIRLPOOL 1e4bda983d10aace2b49df133b76f8fdd9246ce071b09dd00a6aa72c2f2a4fb758214427520170ca6f819ac602199087bf993debd6275e5b23184b5e7f46bff7
diff --git a/dev-ruby/activesupport/activesupport-5.0.2.ebuild b/dev-ruby/activesupport/activesupport-5.0.2.ebuild
new file mode 100644
index 000000000000..7bc5cc1d4e07
--- /dev/null
+++ b/dev-ruby/activesupport/activesupport-5.0.2.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+USE_RUBY="ruby22 ruby23"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activesupport.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Utility Classes and Extension to the Standard Library"
+HOMEPAGE="https://github.com/rails/rails"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~alpha ~amd64 ~arm ~ppc ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ >=dev-ruby/concurrent-ruby-1.0.2:1
+ >=dev-ruby/i18n-0.7:0.7
+ >=dev-ruby/tzinfo-1.1:1
+ >=dev-ruby/minitest-5.1:5"
+
+# memcache-client, nokogiri, and builder are not strictly
+# needed, but there are tests using this code.
+ruby_add_bdepend "test? (
+ >=dev-ruby/dalli-2.2.1
+ >=dev-ruby/nokogiri-1.4.5
+ >=dev-ruby/builder-3.1.0
+ >=dev-ruby/listen-3.0.5:3
+ dev-ruby/rack
+ dev-ruby/mocha:0.14
+ <dev-ruby/minitest-5.4
+ )"
+
+all_ruby_prepare() {
+ # Set the secure permissions that tests expect.
+ chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
+
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ sed -i -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|execjs\|jquery-rails\|mysql\|journey\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|sprockets-rails\|redcarpet\|bcrypt\|uglifier\|minitest\|sprockets\|stackprof\|rack-cache\|sqlite\)/ s:^:#:" \
+ -e '/:job/,/end/ s:^:#:' \
+ -e '/group :doc/,/^end/ s:^:#:' \
+ -e 's/gemspec/gemspec path: "activesupport"/' \
+ -e '5igem "builder"; gem "rack"' ../Gemfile || die
+ rm ../Gemfile.lock || die
+
+ # Avoid test not working within portage
+ sed -i -e '/test_messing_with_either_encrypted_values_causes_failure/askip "gentoo"' test/message_encryptor_test.rb || die
+
+ # Avoid tests failing since test_order cattr is also seen as a test
+ # method
+ rm -f test/xml_mini/libxml{,sax}_engine_test.rb || die
+
+ # Avoid tests that seem to trigger race conditions. This might be
+ # fixed upstream in 7bd41994480c17db71fdc07e3447ade929eaa386
+ rm -f test/evented_file_update_checker_test.rb || die
+}