summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-03-12 09:36:08 +0100
committerHans de Graaff <graaff@gentoo.org>2020-03-12 09:43:56 +0100
commit7d7596421cfe4068b5bc232157332947bee585c3 (patch)
treeea41b5c8b21e4a835dee94833440007e7d56d20f /dev-ruby
parentsys-kernel/vanilla-sources: Automated version bump to 5.5.9 - remove old. (diff)
downloadgentoo-7d7596421cfe4068b5bc232157332947bee585c3.tar.gz
gentoo-7d7596421cfe4068b5bc232157332947bee585c3.tar.bz2
gentoo-7d7596421cfe4068b5bc232157332947bee585c3.zip
dev-ruby/rails-dom-testing: add ruby27
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/rails-dom-testing/rails-dom-testing-2.0.3-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ruby/rails-dom-testing/rails-dom-testing-2.0.3-r1.ebuild b/dev-ruby/rails-dom-testing/rails-dom-testing-2.0.3-r1.ebuild
new file mode 100644
index 000000000000..b920cebb02d7
--- /dev/null
+++ b/dev-ruby/rails-dom-testing/rails-dom-testing-2.0.3-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby24 ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Compare doms and assert certain elements exists in doms using Nokogiri"
+HOMEPAGE="https://github.com/kaspth/rails-dom-testing"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~x86 ~amd64-linux"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/activesupport-4.2.0:*
+ >=dev-ruby/nokogiri-1.6"
+
+each_ruby_test() {
+ ${RUBY} -Ilib:test:. -e 'Dir["test/*_test.rb"].each{|f| require f}' || die
+}