summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-10-31 09:10:10 +0100
committerHans de Graaff <graaff@gentoo.org>2021-10-31 09:11:27 +0100
commit82a0a32320083d86d1862672aaaff2dfdb19c94c (patch)
tree02859f38faca866559f26eefdf5c5f219368e183 /dev-ruby
parentdev-ruby/hiredis: cleanup (diff)
downloadgentoo-82a0a32320083d86d1862672aaaff2dfdb19c94c.tar.gz
gentoo-82a0a32320083d86d1862672aaaff2dfdb19c94c.tar.bz2
gentoo-82a0a32320083d86d1862672aaaff2dfdb19c94c.zip
dev-ruby/hpricot: cleanup
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/hpricot/hpricot-0.8.6-r5.ebuild61
1 files changed, 0 insertions, 61 deletions
diff --git a/dev-ruby/hpricot/hpricot-0.8.6-r5.ebuild b/dev-ruby/hpricot/hpricot-0.8.6-r5.ebuild
deleted file mode 100644
index 4fe2280623e9..000000000000
--- a/dev-ruby/hpricot/hpricot-0.8.6-r5.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-USE_RUBY="ruby24 ruby25 ruby26 ruby27"
-
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.md"
-
-inherit ruby-fakegem epatch
-
-DESCRIPTION="A fast and liberal HTML parser for Ruby"
-HOMEPAGE="https://wiki.github.com/hpricot/hpricot"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm ~arm64 ~hppa ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris ~x86-solaris"
-IUSE=""
-
-ruby_add_bdepend "dev-ruby/rake
- dev-ruby/rdoc
- dev-ruby/rake-compiler"
-
-ruby_add_rdepend "dev-ruby/fast_xs"
-
-# Probably needs the same jdk as JRuby but I'm not sure how to express
-# that just yet.
-DEPEND+=" dev-util/ragel"
-
-all_ruby_prepare() {
- sed -i -e '/[Bb]undler/ s:^:#:' Rakefile || die
-
- # Fix encoding assumption of environment for Ruby 1.9.
- # https://github.com/hpricot/hpricot/issues/52
- # sed -i -e '1 iEncoding.default_external=Encoding::UTF_8 if RUBY_VERSION =~ /1.9/' test/load_files.rb || die
-
- # Avoid unneeded dependency on git.
- sed -i -e '/^REV/ s/.*/REV = "6"/' Rakefile || die
-
- # Fix int size warning
- sed -i -e 's/te - ts/(int)(te - ts)/' ext/hpricot_scan/hpricot_css.rl || die
-}
-
-each_ruby_prepare() {
- pushd .. &>/dev/null
- epatch "${FILESDIR}"/${P}-fast_xs.patch
- popd .. &>/dev/null
-}
-
-each_ruby_configure() {
- ${RUBY} -Cext/hpricot_scan extconf.rb || die "hpricot_scan/extconf.rb failed"
-}
-
-each_ruby_compile() {
- local modname=$(get_modname)
-
- ${RUBY} -S rake ragel || die
- emake V=1 -Cext/hpricot_scan CFLAGS="${CFLAGS} -fPIC" archflag="${LDFLAGS}"
- cp ext/hpricot_scan/hpricot_scan${modname} lib/ || die
-}