summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2019-07-20 09:21:48 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2019-07-20 10:21:36 +0100
commit855d24e4328e1832f970ec10c03468cc1c033f56 (patch)
tree79e7307ab7865eb5132753e70c39c2bdb0d5a7c1 /dev-ruby
parentruby-ng.eclass: add missing 'estack' inherit to EAPI=6 (diff)
downloadgentoo-855d24e4328e1832f970ec10c03468cc1c033f56.tar.gz
gentoo-855d24e4328e1832f970ec10c03468cc1c033f56.tar.bz2
gentoo-855d24e4328e1832f970ec10c03468cc1c033f56.zip
dev-ruby/*: add missing 'versionator' inherit
Noticed failure when ran $ PORTAGE_ELOG_CLASSES="qa" egencache --repo=gentoo --update --update-use-local-desc --jobs=$(nproc) * ERROR: dev-ruby/rspec-expectations-3.7.0::gentoo failed (depend phase): * External commands disallowed while sourcing ebuild: get_version_component_range 1-2 * * Call stack: * ebuild.sh, line 624: Called source '/gentoo-ebuilds/gentoo/dev-ruby/rspec-expectations/rspec-expectations-3.7.0.ebuild' * rspec-expectations-3.7.0.ebuild, line 25: Called command_not_found_handle 'get_version_component_range' '1-2' * ebuild.sh, line 89: Called die * The specific snippet of code: * die "External commands disallowed while sourcing ebuild: ${*}" Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/rspec-core/rspec-core-3.7.1.ebuild2
-rw-r--r--dev-ruby/rspec-expectations/rspec-expectations-3.7.0.ebuild2
-rw-r--r--dev-ruby/rspec-mocks/rspec-mocks-3.7.0.ebuild2
3 files changed, 3 insertions, 3 deletions
diff --git a/dev-ruby/rspec-core/rspec-core-3.7.1.ebuild b/dev-ruby/rspec-core/rspec-core-3.7.1.ebuild
index b04ba6011506..dcaf66c0833c 100644
--- a/dev-ruby/rspec-core/rspec-core-3.7.1.ebuild
+++ b/dev-ruby/rspec-core/rspec-core-3.7.1.ebuild
@@ -14,7 +14,7 @@ RUBY_FAKEGEM_EXTRAINSTALL="exe"
RUBY_FAKEGEM_GEMSPEC="rspec-core.gemspec"
-inherit ruby-fakegem
+inherit ruby-fakegem versionator
DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
HOMEPAGE="https://github.com/rspec/rspec-core"
diff --git a/dev-ruby/rspec-expectations/rspec-expectations-3.7.0.ebuild b/dev-ruby/rspec-expectations/rspec-expectations-3.7.0.ebuild
index 4eb12ad1379a..f7e06817c865 100644
--- a/dev-ruby/rspec-expectations/rspec-expectations-3.7.0.ebuild
+++ b/dev-ruby/rspec-expectations/rspec-expectations-3.7.0.ebuild
@@ -11,7 +11,7 @@ RUBY_FAKEGEM_EXTRADOC="Changelog.md README.md"
RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
-inherit ruby-fakegem
+inherit ruby-fakegem versionator
DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
HOMEPAGE="https://github.com/rspec/rspec-expectations"
diff --git a/dev-ruby/rspec-mocks/rspec-mocks-3.7.0.ebuild b/dev-ruby/rspec-mocks/rspec-mocks-3.7.0.ebuild
index 0ff7248e354b..c348ca0f575e 100644
--- a/dev-ruby/rspec-mocks/rspec-mocks-3.7.0.ebuild
+++ b/dev-ruby/rspec-mocks/rspec-mocks-3.7.0.ebuild
@@ -9,7 +9,7 @@ RUBY_FAKEGEM_RECIPE_TEST="rspec3"
RUBY_FAKEGEM_RECIPE_DOC="none"
RUBY_FAKEGEM_EXTRADOC="Changelog.md README.md"
-inherit ruby-fakegem
+inherit ruby-fakegem versionator
DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
HOMEPAGE="https://github.com/rspec/rspec-mocks"