summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2024-01-21 09:40:30 +0100
committerHans de Graaff <graaff@gentoo.org>2024-01-21 09:40:44 +0100
commit89a8cf8a3732593bb46dfd2b6309855e0063827d (patch)
tree1a880cc5549651a4430eb0e9e30f2550f4a3167c /dev-ruby
parentdev-ruby/activestorage: add 7.1.3 (diff)
downloadgentoo-89a8cf8a3732593bb46dfd2b6309855e0063827d.tar.gz
gentoo-89a8cf8a3732593bb46dfd2b6309855e0063827d.tar.bz2
gentoo-89a8cf8a3732593bb46dfd2b6309855e0063827d.zip
dev-ruby/actiontext: add 7.1.3
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/actiontext/Manifest1
-rw-r--r--dev-ruby/actiontext/actiontext-7.1.3.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-ruby/actiontext/Manifest b/dev-ruby/actiontext/Manifest
index c8ed7fc9b9e1..5d56dd840dfe 100644
--- a/dev-ruby/actiontext/Manifest
+++ b/dev-ruby/actiontext/Manifest
@@ -3,3 +3,4 @@ DIST rails-6.1.7.6.tgz 11040086 BLAKE2B 8b5311752952403cf8eae31b5d8e8d376c4b449f
DIST rails-7.0.8.tgz 11073254 BLAKE2B 2aee047a365acb0890ef3afbccfe323fedccf7b54214aa1c2f92b7a7aaa64c275c1e03f8f97e6a2e30281224ba30703d18b40aeee9b4e7fb6f035a4a7716a054 SHA512 0e9feb5bd0360868c3109152d8ea414b65d36d33a5dbb96b199cfa6c4335800d6c392e0fbcbfa453a02fd75924a297a65caf04948895de53db43700478dbeb11
DIST rails-7.1.1.tgz 10871844 BLAKE2B 12ebcb567f9a8eca58fa0a9c066a8c9c904130a514daa079be4625e0b0ef0ab5744d3dfbff01a146c9053a36ecb77e4f4d381ce8167ec511badcbba7f090b499 SHA512 9a18dc102acaaa1e66aa437ea3de2cc41acd04b7a52792fb686e88f14111a0e32e25a6d093f26badfdca2a932cf458720cbdb1efbcc00c766157741ea99a32f1
DIST rails-7.1.2.tgz 10893031 BLAKE2B 5a91d15e02171ff94d8a09894425bffcf35fc73a40e6bdc16a549d780c152ebd96e67e015af66d4115313d66450ac17b62dd55a7b5a5d10b3d52f215b5d58c1c SHA512 91bb3887ace7d90159052c397797101043565f7b52520832a865fc0b2df11b69162a3a70943b839fb1d26fd8ffe177b3e542e743df04067371f90a11973bdaca
+DIST rails-7.1.3.tgz 10900323 BLAKE2B a83ca4ee656e93241fa0460d8df197904a4eef310cf25bce6db6167bad87c8d0644533fa6e224ec959a4e10005164e0f981e14e8b23cee14e2747117be9da712 SHA512 df1128d1403ab82d218d2057c7c86e646594f97a8c6fcf5648a66440d52e5c20a4ceb0c13e70b6153152b44f62d8a1e20f3776acff5c55bc54d006cb7da32d12
diff --git a/dev-ruby/actiontext/actiontext-7.1.3.ebuild b/dev-ruby/actiontext/actiontext-7.1.3.ebuild
new file mode 100644
index 000000000000..70b801b7a136
--- /dev/null
+++ b/dev-ruby/actiontext/actiontext-7.1.3.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32"
+
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="actiontext.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTRAINSTALL="app db package.json"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Edit and display rich text in Rails applications"
+HOMEPAGE="https://github.com/rails/rails"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="test"
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ ~dev-ruby/actionpack-${PV}
+ ~dev-ruby/activerecord-${PV}
+ ~dev-ruby/activestorage-${PV}
+ ~dev-ruby/activesupport-${PV}
+ >=dev-ruby/globalid-0.6.0
+ >=dev-ruby/nokogiri-1.8.5
+"
+
+ruby_add_bdepend "test? (
+ dev-ruby/bundler
+ dev-ruby/importmap-rails
+ dev-ruby/minitest:5.15
+ dev-ruby/mocha
+ dev-ruby/propshaft
+ >=dev-ruby/sqlite3-1.4.0
+)"
+
+all_ruby_prepare() {
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ sed -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|execjs\|jquery-rails\|mysql2\|journey\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|sass-rails\|debugger\|sprockets-rails\|redcarpet\|bcrypt\|uglifier\|sprockets\|stackprof\|websocket-client-simple\|libxml-ruby\|redis\|blade\|aws-sdk\|google-cloud\|azure-storage\|selenium\|webpacker\|webrick\|webmock\|webdrivers\|minitest-bisect\|minitest-retry\|minitest-reporters\|listen\|rack-cache\|rack-test\|bootsnap\|capybara\|dalli\|connection_pool\|terser\|cookiejar\|cgi\|web-console\|trilogy\|error_highlight\|jbuilder\)/ s:^:#:" \
+ -e '/stimulus-rails/,/cssbundling-rails/ s:^:#:' \
+ -e '/tailwindcss-rails/,/dartsass-rails/ s:^:#:' \
+ -e '/:job/,/end/ s:^:#:' \
+ -e '/group :\(cable\|doc\|lint\|rubocop\|storage\|test\)/,/^end/ s:^:#:' \
+ -e '/sqlite/ s/1.6.4/99/' \
+ -i ../Gemfile || die
+ rm ../Gemfile.lock || die
+
+ # Avoid failing test depending on yarn
+ rm -f test/javascript_package_test.rb || die
+}
+
+each_ruby_prepare() {
+ sed -i -e 's:ruby:'${RUBY}':' test/dummy/bin/* || die
+}